Bug 441312 - Add window titles and icons
Summary: Add window titles and icons
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: git master
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-21 16:52 UTC by Nate Graham
Modified: 2021-09-10 20:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Too large overlays (57.83 KB, image/png)
2021-08-24 10:55 UTC, geisserml
Details
Just in case anyone wants to enframe this conversation (322.11 KB, application/pdf)
2021-09-03 14:49 UTC, geisserml
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2021-08-21 16:52:30 UTC
The window thumbnails do not display titles or icons overlaid upon them like the current Present Windows effect does. It should, because the icons make it easy to switch windows for people whose brains remember app icons rather than window thumbnails (like me). and titles probably help people whose brain remember words.
Comment 1 geisserml 2021-08-22 17:55:42 UTC
No, please don't do this. I already argued about it on Present Windows (Bug 438905).
Overlaying icons makes it harder to distinguish multiple instances of the same application. Reading texts takes too long and defeats the purpose of quickly getting an overview by what the windows look like.
Users who recognise windows by title or icon can use the classical task bar (which is planned to be be interactive in the new Overview effect, right?).
Comment 2 Nate Graham 2021-08-22 23:41:51 UTC
For titles, I can kind of see your point, but icons are a non-negotiable as they are needed to support the use case I mentioned. Yes, you can use the Task Manager for that, but you could use the Task Manager for everything. The point is to make the Overview effect usable for as many people with as many use cases as possible.
Comment 3 geisserml 2021-08-23 10:44:45 UTC
> Yes, you can use the Task Manager for that, but you could use the Task Manager 
> for everything.
No, contrary to the Overview effect, window previews in the task manager are too small, and you don't have the overview of all applications' contents at once.
Task manager -> icon-based app management
Overview -> *quick* identification of apps by content

There is no other possibility to quickly distinguish windows by content except for the Overview effect. Please don't make it unusable with icon overlays.

As a side-node, no other operating system or desktop environment that I know of uses icon overlays in their overview effect. Moreover, icons are already visible in the top-right corner of the application, which should be enough.

> The point is to make the Overview effect usable for as many people with as
> many use cases as possible.
Destroying the primary use case and purpose of **identifying windows by content and getting an overview** doesn't make it more usable to anyone, frankly. One component should do one thing, and do it well.
Comment 4 geisserml 2021-08-23 10:53:32 UTC
> top-right
Whoops, top-left of course. Apparently I've got a right-left weakness :D
Comment 5 apache 2021-08-24 10:17:10 UTC
Why not making it optional? Some users will disable icons and titles some would prefer to have them displayed.

https://pointieststick.com/2021/08/20/this-week-in-kde-some-cool-new-stuff/

> will eventually replace the existing Present Windows effect and probably the Desktop Grid effect as well, unifying them both into a full-screen overview of windows, Virtual Desktops and perhaps Activities too!

For me it is easier to use Present Windows and Desktop Grid with icons and titles, depending on the size of window and the number of windows open. Titles can be under windows and icons in windows corner so that they don't cover window preview.

Take into account that there are users who still use relatively small screens and as a consequence preview windows become small.

Search for the largest monitors in 2021 and compare to 10 years' old 1280x1024 and realize that user experience with Present Windows and Desktop Grid are different.
Comment 6 geisserml 2021-08-24 10:39:44 UTC
> Titles can be under windows and icons in windows corner so that they don't
> cover window preview.
That's a good suggestion.
What I just want to prevent is that icons/titles are made as obtrusive as they were in Present Windows lately. The content of small windows was basically not visible due to being covered by an over-large icon+text, with the rest of the window strongly dimmed, which was annoying...

> Take into account that there are users who still use relatively small screens 
> and as a consequence preview windows become small.
Yep, I'm using such an old, smaller monitor with awkward 5:4 aspect ratio. In spite of this, its stability and visual quality are excellent.
Comment 7 geisserml 2021-08-24 10:46:44 UTC
> [...] and as a consequence preview windows become small.
That's exactly why I dislike overlays on top of windows so much. They hide content of previews which are rather small already, making it even harder to identify the window.
Comment 8 geisserml 2021-08-24 10:55:40 UTC
Created attachment 141003 [details]
Too large overlays

Here's an example from the old Present Windows that should illustrate the problem.
Comment 9 apache 2021-08-24 14:34:50 UTC
This discussion is pointless. Some will want it some don't. 

Current Present windows options have show icons and display windows titles options.
https://i.imgur.com/vkDW34H.png

I don't understand why some users have problem with it. Just keep it optional.
Comment 10 geisserml 2021-08-24 17:36:45 UTC
Oh, indeed it's optional in Present Windows! I never noticed that. What a blunder. Did that option get added recently, or did I just overlook it?
Comment 11 Michał Dybczak 2021-09-02 19:30:29 UTC
Frankly, I have NEVER noticed the titles. I just checked whether they are really showed, and they are - what a surprise!

For me, ICONS are how I quickly recognize windows. Without relatively big icons, the whole overview effect will become useless for me. Whether titles are there or not is without a consequence for me, since I haven't noticed it till now.

As for the case of many instances of the same app: my first search is for the icon, the second one is for the miniature. If I see only miniatures and I can't filter out anything, it's like a spinning carousel and I can't make heads of tails of what I see. It takes too long to recognize anything, and the whole effect would be useless. So the icons are a must, even with multiple instances.

So if the new overview effect lacked of those, IT WOULD BE A MAJOR REGRESSION and you would get flowed with bug reports, at least from persons who use overview effect.

Will the current options be upheld in the new version? I see no reasons why wouldn't they be. Also, the current default icons+titles is a reasonable one IMO.
Comment 12 geisserml 2021-09-02 20:22:03 UTC
Well, obviously I disagree very much.

> Without relatively big icons, the whole overview effect will become useless for me.
*With* icons it becomes useless. The purpose of an overview effect is to quickly recognise open applications by their content, by what they look like. Icons don't tell you anything about what the window is for, what work you want to do in there. Icons don't help at all to get an overview, to see what is going on in different windows.

> my first search is for the icon, the second one is for the miniature
If the icon/text overlay is over-large / centered, it gets too difficult identify and memorise the content, which is the primary purpose of Overview. Icons-based app management is already available with the task bar. Icons are used just about everywhere and I tend to find them disgusting because they usually have very little logical connection to what the app actually does.

> So if the new overview effect lacked of those, IT WOULD BE A MAJOR REGRESSION and you would get flowed with bug reports, at least from persons who use overview effect.
To be clear, removing these annoying overlays would be an IMPROVEMENT and a nice step towards clean, usable code without non-features.

> If I see only miniatures and I can't filter out anything, it's like a spinning carousel and I can't make heads of tails of what I see. It takes too long to recognize anything, and the whole effect would be useless.
Absolutely not. With the visual pattern the whole window makes up, it's very nice to identify, and you can see what is going on inside the window, compare windows, watch windows simultaneously, etc.
In contrast, icons are way too generic. Overview is about *specific open windows*, not about the app in general.

> So the icons are a must, even with multiple instances.
No. Really no. They just make it harder to distinguish multiple instances and hide relevant content. They're nothing more than an annoyance.

> Will the current options be upheld in the new version? I see no reasons why wouldn't they be.
Believe me, I see many, many good reasons.

> Also, the current default icons+titles is a reasonable one IMO.
I would rather think about whether it is worth the effort being implemented at all (especially with Overview being in such an early beta stage), but most clearly icons+titles shouln't be the default.
Comment 13 geisserml 2021-09-02 20:23:13 UTC
too difficult *to identify
pardon
Comment 14 Nate Graham 2021-09-02 21:03:42 UTC
Two things are clear:

1. People use this effect in different ways based on what's most comfortable for them; one size does not fit all.
2. Thew more we argue, the less likely it is that we will agree on anything as we become more entrenched in our original positions.
Comment 15 Vlad Zahorodnii 2021-09-03 06:39:11 UTC
Git commit 43a50be325e09e34406a56854578053df587c1b0 by Vlad Zahorodnii.
Committed on 03/09/2021 at 06:38.
Pushed by vladz into branch 'master'.

effects/overview: Display window icon and caption

M  +35   -0    src/effects/overview/qml/WindowHeap.qml

https://invent.kde.org/plasma/kwin/commit/43a50be325e09e34406a56854578053df587c1b0
Comment 16 geisserml 2021-09-03 10:52:10 UTC
Oh, so to my bad luck this mis-feature got addded. And it seems it's not even optional.
Comment 17 geisserml 2021-09-03 11:22:07 UTC
(In reply to Nate Graham from comment #14)
> Two things are clear:
> 
> 1. People use this effect in different ways based on what's most comfortable
> for them; one size does not fit all.
> 2. The more we argue, the less likely it is that we will agree on anything
> as we become more entrenched in our original positions.
This is much more about logic and UI usability considerations than about taste.
I'd like to repeat that no other operating system or desktop environment overlays centered icons / captions. From a usability perspective they're rubbish, and any trained UI expert will most probably tell you so.
I have already outlined clear reasons in support of this position in my previous comments, none of which have been responded to with substantive counter-arguments (likely because there are no such).
Comment 18 geisserml 2021-09-03 11:39:01 UTC
(In reply to Nate Graham from comment #14)
> 2. Thew more we argue, the less likely it is that we will agree on anything
> as we become more entrenched in our original positions.
I generally prefer good opposition to bad compromises.
And from looking at the code, it gets clear that this can't be called a compromise at all. Just as in Present Windows, the icons/labels will be (over-)large and centered (and, as a disimprovement, not even optional):
```qml
width: PlasmaCore.Units.iconSizes.large
horizontalAlignment: Text.AlignHCenter
verticalAlignment: Text.AlignVCenter
```
Comment 19 Nate Graham 2021-09-03 13:30:36 UTC
Manuel, I am trying to help you be effective here.

You may have noticed that for all the walls of text, you have failed to convince anyone of your viewpoint. Generally, getting things that you want done is rarely about who is right and who is wrong (everyone thinks they're right) but rather using techniques that are *effective*. 

I am suggesting that you try a different approach that will be more effective, rather than writing clearly ineffective walls of argumentative text.

An example of something effective would be filing a new bug report politely asking for the icons and labels to be optional, or even submitting a merge request to implement it.

Do you think you can do something like that?
Comment 20 geisserml 2021-09-03 14:00:45 UTC
> everyone thinks they're right
Some give meaningful reasons, others don't.

> I am trying to help you be effective here.
I care about correct and comprehensible decisions, not necessarily about being effective. And there is no need to mock. Your comment is a bit of a bad joke, honestly.

> than writing clearly ineffective walls of argumentative text.
In other words, you don't care about logical reasons, you probably don't even bother to read them.

> or even submitting a merge request to implement it.
If it were Python I might help, but I do not know any C++ nor QML. I currently don't have the time and interest to learn these programming languages. Plasma is your project, not mine. I'm just an advisory capacity :)
Comment 21 geisserml 2021-09-03 14:08:52 UTC Comment hidden (spam)
Comment 22 Nate Graham 2021-09-03 14:14:46 UTC
I know that this is a bit of a cultural difference. North Americans prefer to persuade by describing effects, while central Europeans prefer to persuade by describing principles. I get it. However in this case your description of principles have failed to convince anyone. Yet you stubbornly double down on them, thinking that if you just explain them even better, people will come around to your position. It's not happening, because people just don't agree with you.

That's why I'm suggesting that you switch to a different approach. I think you have something valuable to contribute, which is why I'm trying to help you be more effective in communicating it.

If you want to ignore that advice and continue to refine your explanation of principles that people disagree with, people will simply start to ignore you--no matter how right you are convinced you are.
Comment 23 geisserml 2021-09-03 14:45:35 UTC
Okay, hiding my comments as spam - really?
Anyway, I think I have expressed my POV clearly and said everything that I consider relevant. This conversations is now a waste of time. If you ever happen to change your mind, feel free to notify me directly via e-mail. I'm demonstratively leaving this conversation now.
As a last remark, I'd be quite interested in the scorcher Martin Keary alias Tantacrul would give you if he ever tested Present Windows or Overview...
Comment 24 geisserml 2021-09-03 14:49:29 UTC
Created attachment 141270 [details]
Just in case anyone wants to enframe this conversation
Comment 25 Nate Graham 2021-09-03 14:52:00 UTC
Yep, we mark comments as spam if they contribute nothing to the discussion--such as your spiteful and passive-aggressive comment implying bad faith on the part of the developers.

We care very much about the UX, we just don't agree with you that showing icons and titles ruins it.
Comment 26 geisserml 2021-09-03 15:29:49 UTC
I don't imply bad faith (you seem to do though?). This was merely something I noticed. And you just confirmed that what I consider usability issues is indeed all intentional.
Comment 27 geisserml 2021-09-04 09:34:21 UTC
One thing I've learned now: Before judging a software project, look at how developers act in its bug tracker. Then you will find out whether they are friendly or unfriendly, competent or incompetent people. Man muß den Bären in seiner Höhle gesehen haben, bevor man ein Urteil über ihn abgeben kann.
And yes, you are officially allowed to mark this as spam if you really want to display yourself in the way you do.
Comment 28 geisserml 2021-09-04 09:40:20 UTC
> I'd be quite interested in the scorcher Martin Keary alias Tantacrul would give 
> you if he ever tested Present Windows or Overview...
Ah, I really can't wait for that scorcher... I need to contact Martin and ask him whether he wants to do it.
Comment 29 Michał Dybczak 2021-09-10 20:01:26 UTC
Manuel, I just explained HOW MY BRAIN PROCESS IT AND I OR YOU CAN'T CHANGE IT. No matter how you argue, it doesn't change anything. There is nothing to agree or disagree upon. I can't disagree on how I feel, nor I can disagree on your feelings as well.

Because you process overview better without icons, doesn't contradict the fact that others, like me, need icons to process it. Forcing one solution or the other would be hurtful to a lot of people. That is why, leaving option to turn on/off icons is just the sanest approach, especially that those options already exist, so we are merely making sure that those won't disappear with the next overview version.

Since the case is RESOLVED FIXED, I assume, this means those options persist, so you get what you want, and I get what I want. All is well and there is nothing to discuss further.