Bug 441241 - When choosing Thumbnail Grid as your Task Switcher, tasks seem to be kept their position while you click the close button
Summary: When choosing Thumbnail Grid as your Task Switcher, tasks seem to be kept the...
Status: RESOLVED FIXED
Alias: None
Product: kdeplasma-addons
Classification: Unclassified
Component: Task Switchers (show other bugs)
Version: 5.22.4
Platform: Manjaro Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-20 14:46 UTC by m11.1l1.f64
Modified: 2022-07-12 21:09 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.3


Attachments
Task Switcher Bug (1.44 MB, video/x-matroska)
2021-08-20 14:46 UTC, m11.1l1.f64
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m11.1l1.f64 2021-08-20 14:46:48 UTC
Created attachment 140878 [details]
Task Switcher Bug

SUMMARY
When choosing Thumbnail Grid as your Task Switcher, tasks seem to be kept their position while you click the close button

STEPS TO REPRODUCE
1. Choose Thumbnail Grid as your Task Switcher in the settings
2. Trigger the Task Switcher with alt + tab
3. Click on the close button

OBSERVED RESULT
The task position still exists

EXPECTED RESULT
The empty space should not be present

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Manjaro
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.12.2

ADDITIONAL INFORMATION
You can watch the attachment for the visual representation
Comment 2 Ismael Asensio 2022-06-28 22:36:13 UTC
Git commit b73b970a683ac3d983c06f67e4c6bd6737cd7289 by Ismael Asensio.
Committed on 28/06/2022 at 22:34.
Pushed by iasensio into branch 'master'.

switchers/thumbnailgrid: Fix layout when window count changes

Assign the column calculation declaratively, so the number of
columns is automatically updated on window count changes
FIXED-IN: 5.25.3

M  +11   -16   windowswitchers/thumbnail_grid/contents/ui/main.qml

https://invent.kde.org/plasma/kdeplasma-addons/commit/b73b970a683ac3d983c06f67e4c6bd6737cd7289
Comment 3 Ismael Asensio 2022-06-28 22:41:37 UTC
Git commit 2b0069baa5bf8b901bfffa288fe1188ef3faaeed by Ismael Asensio.
Committed on 28/06/2022 at 22:41.
Pushed by iasensio into branch 'Plasma/5.25'.

switchers/thumbnailgrid: Fix layout when window count changes

Assign the column calculation declaratively, so the number of
columns is automatically updated on window count changes
FIXED-IN: 5.25.3


(cherry picked from commit b73b970a683ac3d983c06f67e4c6bd6737cd7289)

M  +11   -16   windowswitchers/thumbnail_grid/contents/ui/main.qml

https://invent.kde.org/plasma/kdeplasma-addons/commit/2b0069baa5bf8b901bfffa288fe1188ef3faaeed
Comment 4 Patrick Silva 2022-07-12 14:46:12 UTC
it's still reproducible after update to Plasma 5.25.3.

Operating System: Arch Linux
KDE Plasma Version: 5.25.3
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Graphics Platform: Wayland
Comment 5 Ismael Asensio 2022-07-12 18:36:03 UTC
(In reply to Patrick Silva from comment #4)
> it's still reproducible after update to Plasma 5.25.3.
> 
> Operating System: Arch Linux
> KDE Plasma Version: 5.25.3
> KDE Frameworks Version: 5.96.0
> Qt Version: 5.15.5
> Graphics Platform: Wayland

I cannot reproduce it anymore after the change in 5.25.3. 
I don't know about Arch. Is the kde-plasmaaddons package also at the same version?

I don't know much about Arch, but is the package for kdeplasma-addons also updated to that version?  
I'd think so, but just to be sure
Comment 6 Patrick Silva 2022-07-12 21:09:11 UTC
kdeplasma-addons 5.25.3-1 package is installed. I can reproduce on Wayland and X11.