Bug 440983 - crash after ejecting storage device
Summary: crash after ejecting storage device
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Disks & Devices (show other bugs)
Version: 5.22.4
Platform: Other Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-14 20:28 UTC by kde
Modified: 2022-01-04 04:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
stacktrace (111.48 KB, text/plain)
2021-08-14 20:28 UTC, kde
Details
coredumpctl gdb PID (82.99 KB, text/plain)
2021-08-17 16:21 UTC, kde
Details
"journalctl --user" output (15.54 KB, text/plain)
2021-11-13 19:47 UTC, kde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2021-08-14 20:28:37 UTC
Created attachment 140729 [details]
stacktrace

Operating System: openSUSE Tumbleweed 20210810
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.8-1-default (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 3900X 12-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: Radeon RX 570 Series

Plasmashell crashed right after ejecting a storage device.
In this case it was an SD card, but it has happened with an USB stick as well.

The debugger did not start this time. It started the other time but apparently never finished, the window was just gone after I came back to the PC.

I only have a stacktrace from this time.
Comment 1 Nate Graham 2021-08-16 17:31:54 UTC
I'm afraid that doesn't tell us much. Can you get a backtrace of just the crashing thread? See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports#Retrieving_a_backtrace_using_coredumpctl
Comment 2 kde 2021-08-17 16:21:18 UTC
Created attachment 140800 [details]
coredumpctl gdb PID

I don't think it's helpful, but that's all it gave me.
Comment 3 Nate Graham 2021-08-18 15:12:45 UTC
Indeed, not very useful. :/ I don't think there is any way we can debug this without better debug information, sorry. Please let us know if you can attach one if it happens again!
Comment 4 kde 2021-11-13 19:47:00 UTC
Created attachment 143520 [details]
"journalctl --user" output
Comment 5 kde 2021-11-13 19:48:11 UTC
It happened again today, but DrKonqi was killed before the backtrace had finished.
coredumpctl also has nothing, probably because plasmashell was sigkilled.

Operating System: openSUSE Tumbleweed 20211107
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.14-1-default (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 3900X 12-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: Radeon RX 570 Series
Comment 6 kde 2022-01-03 15:09:14 UTC
Happened again - ejected SD card with right click in Dolphin -> Plasma crashes.

Operating System: openSUSE Tumbleweed 20211220
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.8-1-default (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 3900X 12-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 570 Series

Again DrKonqi was killed before it could finish and coredumpctl shows no dumps.
Comment 7 Nate Graham 2022-01-04 04:21:52 UTC

*** This bug has been marked as a duplicate of bug 427945 ***