Bug 440928 - Crash on start with "Remember Window Size" off and custom size in default session profile.
Summary: Crash on start with "Remember Window Size" off and custom size in default ses...
Status: RESOLVED DUPLICATE of bug 441045
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-13 14:48 UTC by jillianswift
Modified: 2021-08-18 16:08 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jillianswift 2021-08-13 14:48:07 UTC
SUMMARY
With "Remember Window Size" off, and a default session profile with a custom terminal size, konsole crashes on start-up.


STEPS TO REPRODUCE
1. Turn off "Remember Window Size" in Configure Konsole.
2. Make a session profile with larger than usual columns and rows, and make it the default session profile.
3. Close all other Konsole instances.
4. Start a new Konsole instance.
5. Enjoy crash message.

OBSERVED RESULT
Crash on start

EXPECTED RESULT
New konsole instance

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel: 5.13.9 64 bit (Zen)

ADDITIONAL INFORMATION
Comment 1 sb 2021-08-13 20:25:53 UTC
I ran into the same problem after upgrading KDE Gear to 21.08.

To get Konsole to work again, you can edit ~/.config/konsolerc
and set 

[KonsoleWindow]
SaveGeometryOnExit=true



Operating System: Arch Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.9-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-7700K CPU @ 4.20GHz
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 5700 XT
Comment 2 Marc Chester 2021-08-14 22:38:34 UTC
I've had the exact same start-up crash and narrowed it down to the same Remember Window Size option as well. 

Operating System: KDE Neon 5.22 User Edition
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-25-generic (64-bit)
Graphics Platform: X11
Comment 3 catwheezel 2021-08-15 05:20:27 UTC
Confirmed same problem on KDE neon. My konsole profile uses an initial size (102 x 26 rows), and konsole crashes immediately on start.

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel: 5.11.0-26-lowlatency (Ubuntu)
CPU: AMD Ryzen 9 5950X
Comment 4 bastimeyer123 2021-08-15 12:10:31 UTC
Just ran into this issue after upgrading my Arch Linux system.
As already mentioned in the other replies, `SaveGeometryOnExit=true` fixed the issue:

sed -Ei 's/SaveGeometryOnExit=false/SaveGeometryOnExit=true/' "${XDG_CONFIG_HOME:-${HOME}/.config}/konsolerc"

Here's the backtrace log which I was not able to submit via the KDE crash handler as "it didn't contain enough information", in case it matters:

Application: Konsole (konsole), signal: Segmentation fault

[KCrash Handler]
#4  0x00007ff8d43e8f21 in QWindow::winId() const () from /usr/lib/libQt5Gui.so.5
#5  0x00007ff8d366ee32 in KWindowEffects::enableBlurBehind(QWindow*, bool, QRegion const&) () from /usr/lib/libKF5WindowSystem.so.5
#6  0x00007ff8d534ade7 in Konsole::MainWindow::setBlur(bool) () from /usr/lib/libkonsoleapp.so.21
#7  0x00007ff8d534e55c in Konsole::MainWindow::activeViewChanged(Konsole::SessionController*) () from /usr/lib/libkonsoleapp.so.21
#8  0x00007ff8d3f8b75b in ?? () from /usr/lib/libQt5Core.so.5
#9  0x00007ff8d51e9243 in Konsole::ViewManager::activeViewChanged(Konsole::SessionController*) () from /usr/lib/libkonsoleprivate.so.21
#10 0x00007ff8d52139dd in Konsole::ViewManager::createController(Konsole::Session*, Konsole::TerminalDisplay*) () from /usr/lib/libkonsoleprivate.so.21
#11 0x00007ff8d52140ce in Konsole::ViewManager::createView(Konsole::Session*) () from /usr/lib/libkonsoleprivate.so.21
#12 0x00007ff8d534ed53 in Konsole::MainWindow::createSession(QExplicitlySharedDataPointer<Konsole::Profile>, QString const&) () from /usr/lib/libkonsoleapp.so.21
#13 0x00007ff8d534a0d7 in Konsole::Application::newInstance() () from /usr/lib/libkonsoleapp.so.21
#14 0x000055fd09f256fe in ?? ()
#15 0x00007ff8d38e0b25 in __libc_start_main () from /usr/lib/libc.so.6
#16 0x000055fd09f259de in ?? ()
[Inferior 1 (process 3996) detached]
Comment 5 Nate Graham 2021-08-18 16:08:23 UTC

*** This bug has been marked as a duplicate of bug 441045 ***