Bug 440916 - The recurrence events end on date is not the same in other calendars when syncing
Summary: The recurrence events end on date is not the same in other calendars when syn...
Status: RESOLVED NOT A BUG
Alias: None
Product: korganizer
Classification: Applications
Component: recurrence (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-13 08:21 UTC by Hamid R. K. Pishghadam
Modified: 2021-08-17 21:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hamid R. K. Pishghadam 2021-08-13 08:21:23 UTC
SUMMARY
I think there is a problem with showing recurring events that when you set
`end on` field, the last day (the one you specify) is included in the event
but other calendar apps like Android and NextCloud calendar does not include it.

STEPS TO REPRODUCE
1. Add a new event with recurrence set `end on` to like 2 days after start date
2. Sync this calendar with another app like android calendar app

OBSERVED RESULT
The last day of event is one day ahead of other calendar apps

EXPECTED RESULT
The last day of event should be included in the event in the other calendars when syncing the events created from Korganizer

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: ArchLinux
(available in About System)
KDE Plasma Version: 5.22.2
KDE Frameworks Version: 5.83.0
Qt Version: 5.12.2
Comment 1 gjditchfield 2021-08-13 16:09:09 UTC
I can't reproduce this with KOrganizer 5.18.0, Frameworks 5.84.0, and QT 5.15.3.  Can you give me more details about your event?

What I did was create new events with
- start 2021-08-13 10:30 in timezone America/Winnipeg
- end 2021-08-13 11:30 same time zone
- repeats daily, every 1 day
- ends on 2021-08-15
- no exceptions

KOrganizer, Google Calendar's web interface, and Nextcloud"s web interface all show the events on the 13th, 14th, and 15th.
Comment 2 Hamid R. K. Pishghadam 2021-08-17 21:34:19 UTC
Hi,
It seems the problem is with android calendar that treats `ends on` date of the event differently from other calendar apps.

So this bug should be set as not a bug.
And thanks, sorry to take your time.