Bug 440837 - Leaving Do Not Disturb mode causes all the notifications that were suppressed to pop up on screen
Summary: Leaving Do Not Disturb mode causes all the notifications that were suppressed...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Notifications (show other bugs)
Version: master
Platform: Other Linux
: HI normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-08-10 14:55 UTC by Nate Graham
Modified: 2022-03-16 07:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2021-08-10 14:55:17 UTC
STEPS TO REPRODUCE
1. Open a chat client and navigate to a chatty chatroom like the VDG room
2. Enter Do Not Disturb mode
3. Wait 15 minutes
4. Leave Do Not Disturb mode


OBSERVED RESULT
A flood of on-screen notifications ensues, causing the right-hand side of the screen to be full of rapidly scrolling and disappearing notifications for the next minute.


EXPECTED RESULT
Nothing happens; I don't need to see all of the notifications I missed. I missed them on purpose; that's why I entered Do Not Disturb mode.

I could *maybe* see the case for showing these notifications in the history popup (if they are marked as appearing in the history view), but putting them all on screen seems quite noisy and excessive to me.
Comment 1 Bug Janitor Service 2022-03-14 15:20:36 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1565
Comment 2 Fushan Wen 2022-03-16 07:39:13 UTC
Git commit b8b722ba194d5cba15f5d08d6ea2774982888203 by Fushan Wen.
Committed on 16/03/2022 at 07:36.
Pushed by fusionfuture into branch 'master'.

libnotificationmanager: Expire all notifications when "Do not disturb" is on

After leaving "Do not disturb" mode, a flood of on-screen notifications
ensues, causing the right-hand side of the screen to be full of rapidly
scrolling and disappearing notifications for the next minute.

The user doesn't need to see any notification popup that is suppressed
by DnD mode, because the notification can be viewed from the drawer anyway.
FIXED-IN: 5.25

M  +14   -2    libnotificationmanager/abstractnotificationsmodel.cpp
M  +1    -0    libnotificationmanager/abstractnotificationsmodel.h
M  +1    -0    libnotificationmanager/abstractnotificationsmodel_p.h
M  +3    -0    libnotificationmanager/notificationsmodel.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/b8b722ba194d5cba15f5d08d6ea2774982888203