Bug 440781 - Kmail fails to append item/ akonadi db states wrong date format
Summary: Kmail fails to append item/ akonadi db states wrong date format
Status: RESOLVED DUPLICATE of bug 439769
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 5.17.90
Platform: OpenSUSE Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-09 12:14 UTC by Frits Spieker
Modified: 2021-08-09 12:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frits Spieker 2021-08-09 12:14:15 UTC
SUMMARY
Since last update Kmail/ Akonadi fails to get new email from IMAP server. Kmail reports "failed to append item" when synchronising mailbox. The Akonadi error log states: 
2021-08-09T14:00:17 [CRITICAL] org.kde.pim.akonadiserver: DATABASE ERROR:
2021-08-09T14:00:17 [CRITICAL] org.kde.pim.akonadiserver:   Error code: "1292"
2021-08-09T14:00:17 [CRITICAL] org.kde.pim.akonadiserver:   DB error:  "Incorrect datetime value: '2021-08-09T12:00:17Z' for column `akonadi`.`pimitemtable`.`datetime` at row 1"
2021-08-09T14:00:17 [CRITICAL] org.kde.pim.akonadiserver:   Error text: "Incorrect datetime value: '2021-08-09T12:00:17Z' for column `akonadi`.`pimitemtable`.`datetime` at row 1 QMYSQL: Unable to execute query"
2021-08-09T14:00:17 [CRITICAL] org.kde.pim.akonadiserver:   Values: QMap((":0", QVariant(int, 0))(":1", QVariant(QString, "6773"))(":2", QVariant(QString, ""))(":3", QVariant(QString, ""))(":4", QVariant(qlonglong, 21))(":5", QVariant(qlonglong, 3))(":6", QVariant(QDateTime, QDateTime(2021-08-09 12:00:17.471 UTC Qt::UTC)))(":7", QVariant(QDateTime, QDateTime(2021-08-09 12:00:17.471 UTC Qt::UTC)))(":8", QVariant(bool, false))(":9", QVariant(qlonglong, 2491777)))
2021-08-09T14:00:17 [CRITICAL] org.kde.pim.akonadiserver:   Query: "INSERT INTO PimItemTable (rev, remoteId, remoteRevision, gid, collectionId, mimeTypeId, datetime, atime, dirty, size) VALUES (:0, :1, :2, :3, :4, :5, :6, :7, :8, :9)"
2021-08-09T14:00:17 [WARN ] org.kde.pim.akonadiserver: Error during insertion into table "PimItemTable" "Incorrect datetime value: '2021-08-09T12:00:17Z' for column `akonadi`.`pimitemtable`.`datetime` at row 1 QMYSQL: Unable to execute query"
2021-08-09T14:00:17 [WARN ] org.kde.pim.akonadiserver: Error while handling command CreateItem on connection akonadi_imap_resource_0 (0x559fee8e4a30)
2021-08-09T14:00:26 [INFO ] org.kde.pim.akonadiserver: Subscriber "MessageViewerMonitor - 94908118964128" disconnected
2021-08-09T14:00:26 [INFO ] org.kde.pim.akonadiserver: Subscriber "MessageListTagMonitor - 94908119944352" disconnected
2021-08-09T14:00:26 [INFO ] org.kde.pim.akonadiserver: Subscriber "KMail Kernel ETM - 94908118071664" disconnected
2021-08-09T14:00:26 [INFO ] org.kde.pim.akonadiserver: Subscriber "SpecialCollectionsMonitor - 94908118206576" disconnected
2021-08-09T14:00:26 [INFO ] org.kde.pim.akonadiserver: Subscriber "FilterManagerTagMonitor - 94908124039120" disconnected
2021-08-09T14:00:26 [INFO ] org.kde.pim.akonadiserver: Subscriber "TagActionManagerMonitor - 94908124186832" disconnected


This even happens with a completely new user set up. The directory structure as present on the IMAP server is correctly created in KMAIL upon setup, but retrieving messages fails with the above error. 

STEPS TO REPRODUCE
1. Try to get new mail from imap server


OBSERVED RESULT
KMAIL states "failed to append item" and does not show emails coming in upon sync; as a result all email folders are empty and stay empty when setting up as a new user.

EXPECTED RESULT
Emails actually show up in Kmail

I´ĺl happily create any logfile or anything else you need to squash this ugly bug

OS: OpenSuse Tumbleweed
KDE:5.22.4
KDE Framework: 5.84.0
Comment 1 Antonio Rojas 2021-08-09 12:29:14 UTC

*** This bug has been marked as a duplicate of bug 439769 ***