Bug 440730 - Spectacle Crashed
Summary: Spectacle Crashed
Status: RESOLVED WORKSFORME
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: Open/save dialogs (show other bugs)
Version: 5.84.0
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-08-08 09:49 UTC by simplejohn
Modified: 2021-09-17 04:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simplejohn 2021-08-08 09:49:57 UTC
Application: spectacle (21.04.3)
 (Compiled from sources)
Qt Version: 5.15.2
Frameworks Version: 5.84.0
Operating System: Linux 5.13.8-arch1-1 x86_64
Windowing System: X11
Drkonqi Version: 5.22.4
Distribution: Arch Linux

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

Crashed during creation of folder in google drive network folder.
Failed to create Folder on google drive network folder.

The crash can be reproduced every time.

-- Backtrace:
Application: Spectacle (spectacle), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f803b8ebbbb in QLineEdit::text() const () from /usr/lib/libQt5Widgets.so.5
#5  0x00007f8034ebe829 in ?? () from /usr/lib/libKF5KIOFileWidgets.so.5
#6  0x00007f803acfd75b in ?? () from /usr/lib/libQt5Core.so.5
#7  0x00007f803be9fdbd in KJob::result(KJob*, KJob::QPrivateSignal) () from /usr/lib/libKF5CoreAddons.so.5
#8  0x00007f803bea0bec in KJob::finishJob(bool) () from /usr/lib/libKF5CoreAddons.so.5
#9  0x00007f803acfd75b in ?? () from /usr/lib/libQt5Core.so.5
#10 0x00007f803c1e1187 in KIO::SlaveInterface::error(int, QString const&) () from /usr/lib/libKF5KIOCore.so.5
#11 0x00007f803c1e3335 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libKF5KIOCore.so.5
#12 0x00007f803c1e18ea in KIO::SlaveInterface::dispatch() () from /usr/lib/libKF5KIOCore.so.5
#13 0x00007f803c1e63eb in KIO::Slave::gotInput() () from /usr/lib/libKF5KIOCore.so.5
#14 0x00007f803acfd75b in ?? () from /usr/lib/libQt5Core.so.5
#15 0x00007f803acf34ff in QObject::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#16 0x00007f803b79cd62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#17 0x00007f803acc63aa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#18 0x00007f803acc94a9 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQt5Core.so.5
#19 0x00007f803ad1f9a4 in ?? () from /usr/lib/libQt5Core.so.5
#20 0x00007f8038d4610c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0x00007f8038d99b99 in ?? () from /usr/lib/libglib-2.0.so.0
#22 0x00007f8038d43871 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0x00007f803ad1efd6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#24 0x00007f803acc4d1c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#25 0x00007f803b9b125e in QDialog::exec() () from /usr/lib/libQt5Widgets.so.5
#26 0x00007f803b9b1126 in QDialog::exec() () from /usr/lib/libQt5Widgets.so.5
#27 0x00005597cc543422 in ?? ()
#28 0x00005597cc54c6f2 in ?? ()
#29 0x00007f803acfd75b in ?? () from /usr/lib/libQt5Core.so.5
#30 0x00007f803b796203 in QAction::triggered(bool) () from /usr/lib/libQt5Widgets.so.5
#31 0x00007f803b798f18 in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQt5Widgets.so.5
#32 0x00007f803b896442 in ?? () from /usr/lib/libQt5Widgets.so.5
#33 0x00007f803b896595 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5Widgets.so.5
#34 0x00007f803b9944db in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5Widgets.so.5
#35 0x00007f803b7e00be in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#36 0x00007f803b79cd62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#37 0x00007f803b7a4ac9 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#38 0x00007f803acc63aa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#39 0x00007f803b7a357b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /usr/lib/libQt5Widgets.so.5
#40 0x00007f803b7f9a84 in ?? () from /usr/lib/libQt5Widgets.so.5
#41 0x00007f803b7fcdb5 in ?? () from /usr/lib/libQt5Widgets.so.5
#42 0x00007f803b79cd62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#43 0x00007f803acc63aa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#44 0x00007f803b09f210 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/libQt5Gui.so.5
#45 0x00007f803b0747e5 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Gui.so.5
#46 0x00007f8035898fac in ?? () from /usr/lib/libQt5XcbQpa.so.5
#47 0x00007f8038d4610c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0x00007f8038d99b99 in ?? () from /usr/lib/libglib-2.0.so.0
#49 0x00007f8038d43871 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0x00007f803ad1efd6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#51 0x00007f803acc4d1c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#52 0x00007f803accd284 in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#53 0x00005597cc5358b1 in ?? ()
#54 0x00007f803a652b25 in __libc_start_main () from /usr/lib/libc.so.6
#55 0x00005597cc535dee in ?? ()
[Inferior 1 (process 92199) detached]

Possible duplicates by query: bug 438235, bug 426090, bug 425619, bug 423132, bug 422962.

Reported using DrKonqi
Comment 1 Méven Car 2021-08-18 17:58:28 UTC
This isn't likely a spectacle bug but a kfilewidgets bug.

Can your reliably reproduce the crash ?

Could you install the debug symbols for kio ?
(I have to ask even if Arch does not provide them for now).

Could describe more precisely the steps to reproduce the crash conditions ?
Comment 2 Bug Janitor Service 2021-09-02 04:36:11 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2021-09-17 04:36:01 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!