Bug 440598 - Fonts rendering / anti-aliasing not work on plasma v5.22.4
Summary: Fonts rendering / anti-aliasing not work on plasma v5.22.4
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.22.4
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-08-04 18:18 UTC by MitraX
Modified: 2021-10-16 17:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23


Attachments
KDE Plasma v5.22.4 fonts rendering issue for Gtk/GNOME applications (42.50 KB, image/png)
2021-08-04 18:18 UTC, MitraX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MitraX 2021-08-04 18:18:13 UTC
Created attachment 140519 [details]
KDE Plasma v5.22.4 fonts rendering issue for Gtk/GNOME applications

SUMMARY

After the latest upgrade to plasma v5.22.4, fonts rendering/anti-aliasing not working anymore for Gtk/GNOME applications (e.g. GIMP, Inkscape, LibreOffice...)

STEPS TO REPRODUCE
1. Open any Gtk/GNOME application (e.g. GIMP, Inkscape, LibreOffice)


OBSERVED RESULT

Fonts inside the application and menus are not properly rendered/anti-aliased. (see attachment)


EXPECTED RESULT

Fonts should be displayed and rendered as for core KDE applications.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon
(available in About System)
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-08-04 21:40:03 UTC
Cannot reproduce.

Is this happening in X11 or Wayland or both? If it's Wayland only, it would be a regression from the fix for Bug 438971.
Comment 2 MitraX 2021-08-05 07:08:30 UTC
(In reply to Nate Graham from comment #1)
> Cannot reproduce.
> 
> Is this happening in X11 or Wayland or both? If it's Wayland only, it would
> be a regression from the fix for Bug 438971.

I've just tested and it happens in both X11 and Wayland
Comment 3 Nate Graham 2021-08-06 17:59:51 UTC
OK, thanks. Any chance you can test out 5.23? I recall a commit that fixed it there.
Comment 4 MitraX 2021-08-06 23:03:25 UTC
Unfortunately not, this is a production environment
Comment 5 MitraX 2021-08-14 20:29:17 UTC
Is there any particular reason why status of the issue is "NEEDSINFO WAITINGFORINFO"?

I mean, is there anything else I can provide from my side? It's pretty strange that nobody else confirmed this; did you manage to reproduce on your environment(s)?
Comment 6 Nate Graham 2021-08-16 15:14:53 UTC
I cannot reproduce the issue, no. I am pretty sure this is fixed already in Plasma 5.23, but please don't hesitate to re-open it if you find that it's still broken for you once you upgrade to 5.23. Then we can do some more investigation.
Comment 7 MitraX 2021-10-16 17:41:39 UTC
Update for KDE Plasma v5.23 - I can confirm that the issue is fixed but Anti-Aliasing configuration in System Settings > Appearance > Fonts need to be refreshed, i.e. disabled (and saved) than enabled (and saved) again for the fix to be visible.