Bug 440592 - Shrinking window in size make "Network and System" information widget's text overlap instead to elide on X11 only
Summary: Shrinking window in size make "Network and System" information widget's text ...
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.90
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-04 15:53 UTC by postix
Modified: 2022-01-27 19:35 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
Screenshot (197.62 KB, image/png)
2021-08-04 15:53 UTC, postix
Details
Screenshot on 5.23 (243.96 KB, image/png)
2021-10-25 09:13 UTC, postix
Details
Screenshot: KDE Neon Unstable (141.53 KB, image/png)
2022-01-17 19:03 UTC, postix
Details
Screenshot: KDE Neon Unstable 2 (113.43 KB, image/png)
2022-01-17 19:08 UTC, postix
Details
Screenshot: KDE Neon Unstable (Wayland) (199.74 KB, image/png)
2022-01-17 19:14 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2021-08-04 15:53:09 UTC
Created attachment 140517 [details]
Screenshot

SUMMARY

Please see the screenshot. 
Either the minimum window width needs be at least large enough to make it fit all content, the text needs to elide or the widgets have to alter their shape.


SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210730
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.4-1-default (64-bit)
Graphics Platform: X11


ADDITIONAL INFORMATION
Scaling: 2.0
Comment 1 Nate Graham 2021-08-04 18:10:58 UTC
Everything should be elided instead of overlapping; that's what happens for me at least with 200% scaling as well.

Are you using any non-default font sizes or font DPI settings?
Comment 2 postix 2021-08-04 18:14:38 UTC
> Are you using any non-default font sizes or font DPI settings?

I use Noto Sans 10pt for everything but Mono-Fonts (Hack 9pt) and "small fonts" (Noto Sans 8pt).

The scaling was set to 200% via the Systemsettings and the font dpi settings was left untouched: It was automatically adjusted to "force dpi: 192".
Comment 3 Nate Graham 2021-08-04 18:15:48 UTC
Gotcha. In that case it must be that the code to fix this is 5.23 only. I know a bunch of changed were made for this recently, and I'm using the git master version and I don't see the problem any more (and I used to).
Comment 4 postix 2021-08-04 18:17:26 UTC
(In reply to Nate Graham from comment #3)
> Gotcha. In that case it must be that the code to fix this is 5.23 only.

Alright, I will check it again in 5.23 or it's beta. :)
Comment 5 postix 2021-09-03 12:23:36 UTC
(In reply to Nate Graham from comment #3)
> Gotcha. In that case it must be that the code to fix this is 5.23 only. I
> know a bunch of changed were made for this recently, and I'm using the git
> master version and I don't see the problem any more (and I used to).

I have a question regarding testing this:

I have compiled plasma-systemmonitor 5.22.80 (master) using kdesrc-build against Qt 5.15.2 and frameworks 5.86.0 and still see this bug.

What else do I need to take into account?
Comment 6 postix 2021-09-03 12:31:17 UTC
I face the same issue also in the tree view of the "processes" page fwiw.
Comment 7 Nate Graham 2021-09-03 14:45:49 UTC
That's very strange...
Comment 8 postix 2021-10-25 09:13:10 UTC
Created attachment 142847 [details]
Screenshot on 5.23

> I face the same issue also in the tree view of the "processes" page fwiw.
This detail seems to be fixed, however...


(In reply to postix from comment #4)
> Alright, I will check it again in 5.23 or it's beta. :)

I am now on

Operating System: openSUSE Tumbleweed 20211016
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2

and still experience this problem. Does anyone else?
Comment 9 postix 2021-11-29 13:46:21 UTC
I can also reproduce it on Fedora 35.
Comment 10 postix 2022-01-17 19:03:19 UTC
Created attachment 145592 [details]
Screenshot: KDE Neon Unstable

Reproducible in KDE Neon Unstable (5.24.80, 5.90.0, 5.15.3), X11, 200% scaling, running a VBox.
Comment 11 postix 2022-01-17 19:08:53 UTC
Created attachment 145593 [details]
Screenshot: KDE Neon Unstable 2

This seems to be a pure X11 issue! When I switch to Wayland it's not reproducible, switching back to X11 it is!
Comment 12 postix 2022-01-17 19:10:42 UTC
The image attached in the comment is also from X11, but shows additionally that also the "circle"-widgets show this issue.
Comment 13 postix 2022-01-17 19:14:41 UTC
Created attachment 145594 [details]
Screenshot: KDE Neon Unstable (Wayland)

What I also found is that the minimal width/height to which the window can be shrink, is lower on X11 than on Wayland. Maybe that's the reason why it cannot be observered there.
Comment 14 Bug Janitor Service 2022-01-27 15:04:36 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/libksysguard/-/merge_requests/209
Comment 15 Arjen Hiemstra 2022-01-27 15:05:44 UTC
*** Bug 449145 has been marked as a duplicate of this bug. ***
Comment 16 Nate Graham 2022-01-27 19:34:33 UTC
Git commit cb5ead36d9302b004951d97c822924db9ea21548 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 27/01/2022 at 19:33.
Pushed by ngraham into branch 'master'.

faces/textonly: Set grouped header to fill width so it elides properly

Otherwise, the text overflows the face's container and we get some
rather ugly results with long network names in System Monitor and other
places.

M  +1    -0    faces/facepackages/textonly/contents/ui/GroupedText.qml

https://invent.kde.org/plasma/libksysguard/commit/cb5ead36d9302b004951d97c822924db9ea21548
Comment 17 Nate Graham 2022-01-27 19:35:04 UTC
Git commit dc910efe1d419e9b04e6966fbf05b9d2593e753a by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 27/01/2022 at 19:35.
Pushed by ngraham into branch 'Plasma/5.24'.

faces/textonly: Set grouped header to fill width so it elides properly

Otherwise, the text overflows the face's container and we get some
rather ugly results with long network names in System Monitor and other
places.


(cherry picked from commit cb5ead36d9302b004951d97c822924db9ea21548)

M  +1    -0    faces/facepackages/textonly/contents/ui/GroupedText.qml

https://invent.kde.org/plasma/libksysguard/commit/dc910efe1d419e9b04e6966fbf05b9d2593e753a