Bug 440525 - Power profiles slider handle sometimes snaps back to current position when manipulated
Summary: Power profiles slider handle sometimes snaps back to current position when ma...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Battery Monitor (show other bugs)
Version: 6.0.4
Platform: Arch Linux Linux
: VHI normal
Target Milestone: 1.0
Assignee: David Redondo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-02 15:55 UTC by Nate Graham
Modified: 2024-05-18 09:28 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Slider handle snaps back (1.18 MB, video/webm)
2021-08-02 15:55 UTC, Nate Graham
Details
dbis-monitor --pcap output (7.57 KB, text/plain)
2021-08-04 15:50 UTC, Nate Graham
Details
.pcap log file (42.59 KB, application/vnd.tcpdump.pcap)
2021-08-10 14:44 UTC, Nate Graham
Details
System bus dbus log as well (40.55 KB, application/vnd.tcpdump.pcap)
2021-08-10 14:49 UTC, Nate Graham
Details
system dbus log with sudo (49.16 KB, application/vnd.tcpdump.pcap)
2021-08-10 15:08 UTC, Nate Graham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2021-08-02 15:55:55 UTC
Created attachment 140466 [details]
Slider handle snaps back

See attached screen recording.

This seems to happen reliably for me when performance mode is not being inhibited, but I have occasionally seen it happen when performance mode is not being inhibited.
Comment 1 David Redondo 2021-08-03 07:18:24 UTC
Can you record a dbus log when this happens, bonus points in pcap format (--pcap option of dbus-monitor)
Comment 2 Nate Graham 2021-08-04 15:50:41 UTC
Created attachment 140516 [details]
dbis-monitor --pcap output

Attached.
Comment 3 David Redondo 2021-08-05 07:06:11 UTC
Hmm I cannot open the file, is the format broken somehow? I think you just pasted the output, try writing it directly to a file. But indeed I can sport in there the profile changes back to balanced. Can you get me a system bus log as well?
Comment 4 Nate Graham 2021-08-06 17:21:34 UTC
Yeah I just pasted the terminal output.
Comment 5 Nate Graham 2021-08-10 14:44:35 UTC
Created attachment 140636 [details]
.pcap log file

Okay, here is a new log file in hopefully the correct format.
Comment 6 Nate Graham 2021-08-10 14:49:07 UTC
Created attachment 140637 [details]
System bus dbus log as well

System bus log in .pcap format, as requested
Comment 7 Nate Graham 2021-08-10 15:08:57 UTC
Created attachment 140638 [details]
system dbus log with sudo

system dbus log with sudo, for good measure
Comment 8 David Redondo 2021-08-11 07:14:09 UTC
From the system log

- we call setProfile
- the profile changes
- the profile changes back

So looks like an upstream issue. Out of interest which version of ppd are you running? It seems it's not the latest version judging from that you see inhibitions, maybe you can try updating ppd
Comment 9 Nate Graham 2021-08-11 13:40:32 UTC
I have 0.8.1. Looks like 9.0 was released about three weeks ago, but it isn't shipped in Fedora yet. 9.0 replaces inhibition with degradation, so given that the bug affects a feature that has been removed in a released version, this is probably not worth reporting upstream or doing further investigation.

Thanks!
Comment 10 Nate Graham 2022-01-15 23:11:38 UTC
I have the latest version of PPD now which does degradation rather than inhibition, and unfortunately it's still happening.

If this is an upstream issue, what should I report upstream?
Comment 11 Dashon 2024-05-17 20:09:02 UTC
This bug seems to have popped up again in Arch on 6.04. Perhaps related to Qt 6.7. Have reproduced on both intel and amd gpus.
Comment 12 orychalk 2024-05-17 21:43:27 UTC
Hi, Same bug for me.
Fresh Manjaro with Plasma 6 install.
On each click, slider come back to the initial position.
With OSD (META+B), the profile change well.
Comment 13 orychalk 2024-05-17 21:45:27 UTC
(In reply to orychalk from comment #12)
> Hi, Same bug for me.
> Fresh Manjaro with Plasma 6 install.
> On each click, slider come back to the initial position.
> With OSD (META+B), the profile change well.

Operating System: Manjaro Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
QtVersion: 6.7.0
Kernel Version: 6.9.0-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel Core i7-7700K CPU @ 4.20GHz
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 6600
Comment 14 Nate Graham 2024-05-18 00:03:58 UTC
Yeah, and it got later fixed in our code for 6.1.

At that point, when it happens it's because the firmware isn't allowing the change.
Comment 15 orychalk 2024-05-18 09:28:40 UTC
(In reply to Nate Graham from comment #14)
> Yeah, and it got later fixed in our code for 6.1.
> 
> At that point, when it happens it's because the firmware isn't allowing the
> change.

OK thanks.