Bug 440481 - PageUp/PageDown keys do not work in lists where up/down keys do work
Summary: PageUp/PageDown keys do not work in lists where up/down keys do work
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.22.4
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-08-01 10:17 UTC by slartibart70
Modified: 2021-08-09 17:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23


Attachments
ssymon (153.60 KB, image/png)
2021-08-04 08:12 UTC, slartibart70
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slartibart70 2021-08-01 10:17:23 UTC
The systemmonitor 5.22.4 does not react on mouse-scroll inputs nor page-up/down keys, it seems only the cursor keys are working in the list views of 
- the overview page, in 'applications' panel
- in processes page, in processes panel

(and yes, mouse-wheel is working fine everywhere else on this machine :-D)
Comment 1 Nate Graham 2021-08-02 20:49:54 UTC
Works for me with a mouse scroll wheel, a touchpad two-finger scroll gesture, and also a touchscreen single-finger swipe.

Can you attach a screenshot of the app? I wonder if you're missing some packages. Also, are you using any non-default input settings? Is this is X11 or Wayland?
Comment 2 slartibart70 2021-08-04 08:12:02 UTC
Created attachment 140502 [details]
ssymon
Comment 3 slartibart70 2021-08-04 08:16:59 UTC
added screenshot
System is fc34, X11, zawertun copr repos

Symptoms:
in the screenshot, go to lower panel (Applications) 
Cursor keys (up, down) work ok, 
home/end, pgUp, pgDown have no effect

Same on 'Applications' and 'History' if selected from sidebar. The right-hand side list is only reacting to up/down cursor keys

One thing that has improved since last update is:
mouse scroll wheel now works in all lists
Comment 4 Nate Graham 2021-08-04 17:08:17 UTC
I can confirm PageUp/PageDown now working. Since scroll wheel support is now working for yo, let's use the bug to track that other issue.
Comment 5 Felipe Kinoshita 2021-08-05 00:43:40 UTC
What action should page-up and page-down trigger here?
Comment 6 Nate Graham 2021-08-05 02:00:09 UTC
Scrolling the list's scrollview.
Comment 7 Bug Janitor Service 2021-08-05 21:11:11 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-systemmonitor/-/merge_requests/157