Bug 440449 - PIM events plugin in Digital Clock can no longer be configured with latest kdeplasma-addons
Summary: PIM events plugin in Digital Clock can no longer be configured with latest kd...
Status: RESOLVED FIXED
Alias: None
Product: kdepim
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Other
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: regression
: 441007 441453 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-31 16:15 UTC by Kishore Gopalakrishnan
Modified: 2021-08-24 06:58 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.08.1


Attachments
Screenshot showing the label-less checkbox and empty config item in the sidebar (39.06 KB, image/png)
2021-07-31 16:15 UTC, Kishore Gopalakrishnan
Details
Annotated screenshot showing the label-less checkbox and empty config item in the sidebar (89.18 KB, image/png)
2021-07-31 16:25 UTC, Kishore Gopalakrishnan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kishore Gopalakrishnan 2021-07-31 16:15:27 UTC
Created attachment 140422 [details]
Screenshot showing the label-less checkbox and empty config item in the sidebar

SUMMARY
With kdepim-addons 21.07.90, the checkbox for 'PIM events plugin' in the Digital Clock applet's settings no longer shows any text (see attached screenshot). When the plugin is enabled, a blank space is shown in the sidebar of the configure dialog (instead of the icon to configure the PIM events plugin). Clicking on this blank icon does nothing.

STEPS TO REPRODUCE
1. Right click on the Digital Clock > configure Digital Clock > Calendar
2. Note that the third checkbox under 'available plugins' does not have any corresponding text
3. Tick this checkbox and click 'apply'
4. Note that an empty item appears in the sidebar of the config window; click this item

OBSERVED RESULT
The checkbox corresponding to the 'PIM events plugin' has no text. Once it is checked, an empty config page appears.

EXPECTED RESULT
The checkbox for the PIM events plugin should have the correct labelling text, and enabling it should show a page that allows to configure the plugin (choose shown calendars etc.)

SOFTWARE/OS VERSIONS
kdepim-addons version: 21.07.90
KDE Gear version: 21.07.90
Operating System: Arch Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
1. The calendar events are still shown in the applet if they were already configured, so it looks like this is just an issue with opening the config page.
2. Downgrading kdepim-addons to 21.04.3 fixes the issue. 
3. Issue is reproducible on Arch Linux and KDE Neon Unstable, so does not appear to be a packaging issue.
4. I am not sure if this is a bug in the Digital Clock plasmoid or in kdepim-addons, so I am reporting it here.
5. When I compare the journald logs with kdepim-addons 21.04.3 and kdepim-addons 21.07.90, the following two extra lines appear with the older (working) version when I enable the 'pim events plugin' checkbox and then open the 'pim events plugin' config page:

Jul 31 14:47:08 kishorearchtestingVM akonadiserver[781]: 
org.kde.pim.akonadiserver: Subscriber 
Akonadi::Server::NotificationSubscriber(0x7fecdc1357c0) identified as 
"plasmashell-1734759293 - 94432534283376"
Jul 31 14:47:11 
kishorearchtestingVM akonadiserver[781]: org.kde.pim.akonadiserver: 
Subscriber "plasmashell-1734759293 - 94432534283376" disconnected

These lines are not found in the log when I use kdepim-addons 21.07.90
Comment 1 Kishore Gopalakrishnan 2021-07-31 16:25:03 UTC
Created attachment 140423 [details]
Annotated screenshot showing the label-less checkbox and empty config item in the sidebar
Comment 2 Nate Graham 2021-08-02 19:13:00 UTC
wuh-oh.
Comment 3 Bug Janitor Service 2021-08-15 06:17:44 UTC
A possibly relevant merge request was started @ https://invent.kde.org/pim/kdepim-addons/-/merge_requests/13
Comment 4 Kishore Gopalakrishnan 2021-08-15 12:20:54 UTC
Git commit 3fb106d71338339dcf589f396a8d101ffd1cebff by Kishore Gopalakrishnan.
Committed on 15/08/2021 at 06:09.
Pushed by alex into branch 'release/21.08'.

Re-add servicetype for pimeventsplugin

The removal of this in commit 95186ed513a76402b8539f833ed7beed4fdcb799
breaks the configuration page in Plasma's Digital Clock settings.

M  +3    -0    plugins/plasma/pimeventsplugin/pimeventsplugin.json

https://invent.kde.org/pim/kdepim-addons/commit/3fb106d71338339dcf589f396a8d101ffd1cebff
Comment 5 Antonio Rojas 2021-08-15 15:07:03 UTC
*** Bug 441007 has been marked as a duplicate of this bug. ***
Comment 6 Colin J Thomson 2021-08-24 06:58:07 UTC
*** Bug 441453 has been marked as a duplicate of this bug. ***