Bug 440402 - Add option to start collecting history data immediately
Summary: Add option to start collecting history data immediately
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Unclassified
Component: general (show other bugs)
Version: 5.22.4
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: usability
: 451861 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-30 03:10 UTC by Alex
Modified: 2022-05-11 20:36 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2021-07-30 03:10:30 UTC
I assume the reason systemmonitor doesn't already do this is for performance/memory reasons. However, it would be nice to have an option to enable this, because quite regularly I find myself trying to check something that just happened to my system in the History graph, only for it to not have been recorded because I hadn't opened the History tab since starting the app.
Comment 1 Nate Graham 2021-07-30 14:26:48 UTC
Seems reasonable.
Comment 2 David Redondo 2022-04-28 13:47:57 UTC
*** Bug 451861 has been marked as a duplicate of this bug. ***
Comment 3 Arjen Hiemstra 2022-05-11 20:36:36 UTC
Git commit 81222c5fe580fe94aa033de095c7b1022d8f7a43 by Arjen Hiemstra.
Committed on 05/05/2022 at 16:23.
Pushed by ngraham into branch 'master'.

Add a page option to allow preloading a page

For certain pages, it is useful to be able to load the page as soon as
possible so graphs can already start collecting data. This adds an
option to the page configuration that specifies when to load a page -
either on demand on during startup. By default pages will still be
loaded on demand.

M  +3    -1    src/page/EditablePage.qml
M  +6    -0    src/page/EditablePageAction.qml
M  +22   -0    src/page/PageDialog.qml

https://invent.kde.org/plasma/plasma-systemmonitor/commit/81222c5fe580fe94aa033de095c7b1022d8f7a43