Bug 440316 - Track Mouse effect doesn't work when caps lock is on (Wayland)
Summary: Track Mouse effect doesn't work when caps lock is on (Wayland)
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.27.8
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-27 04:19 UTC by k2squared
Modified: 2024-04-27 13:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description k2squared 2021-07-27 04:19:05 UTC
On Wayland, the Track Mouse desktop effect animation doesn't work when caps lock is on.

1) Enable Track Mouse in desktop effects.
2) Turn on caps lock.
3) Press the default key combo to activate the Track Mouse animation: ctrl+meta. Nothing happens.
4) Turn off caps lock and press ctrl+meta again. The animation displays as expected.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210725
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.4-1-default (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i7-6600U CPU @ 2.60GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 520
Comment 1 Patrick Silva 2021-10-30 14:18:44 UTC
Can reproduce on neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 2 David Edmundson 2023-09-06 10:38:27 UTC
This bug was reported against an outdated version of KWin. We have made many changes since the. 
If the issue persists in newer versions can you reopen the bug report updating the version number.
Comment 3 Patrick Silva 2023-09-16 16:33:31 UTC
It's still reproducible.

Operating System: Arch Linux 
KDE Plasma Version: 5.27.8
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Graphics Platform: Wayland
Comment 4 Zamundaaa 2023-09-19 12:58:44 UTC
The modifiers this effect is querying contain "shift" when capslock is on, which causes this problem.

As this sort of problem has come up a fair few times so far, maybe we should separate modifiers into "pressed" and "locked", like Wayland already does.
Comment 5 Zamundaaa 2024-04-27 13:06:10 UTC
I just noticed that it works now; I fixed it with https://invent.kde.org/plasma/kwin/-/commit/8c543dbe7c8a00f47f3022b7cad4d97b1436b659