Bug 440314 - Screen Brightness slider shows no percentage
Summary: Screen Brightness slider shows no percentage
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_powerdevil (show other bugs)
Version: 5.22.3
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 451320 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-27 03:21 UTC by coderbaka
Modified: 2022-04-08 23:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description coderbaka 2021-07-27 03:21:00 UTC
SUMMARY
Screen Brightness slider shows no percentage. It's not a bug, but it's more handy to show current percentage of brightness like in the Battery and Brightness applet. 

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Archlinux 
(available in About System)
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2022-03-23 13:15:30 UTC
*** Bug 451320 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2022-04-08 23:39:10 UTC
Git commit 04815f45fe4c568e9965a1bd13ad90d2864b9906 by Nate Graham, on behalf of Edo Friedman.
Committed on 08/04/2022 at 23:39.
Pushed by ngraham into branch 'master'.

Add percentage display next to the brightness and keyboard backlight sliders in KCM

Currently if you were to open System Settings and go to the
Power Management -> Energy Saving KCM, you will see the "Screen Brightness"
and "Keyboard Backlight" sliders, but there will be no way to know the exact
number you selected until you apply the change and look at the "Energy Saving"
applet. This commit changes that by adding percentage labels to the right of
both sliders.
FIXED-IN: 5.25

M  +6    -1    daemon/actions/bundled/brightnesscontrolconfig.cpp
M  +2    -0    daemon/actions/bundled/brightnesscontrolconfig.h
M  +6    -0    daemon/actions/bundled/keyboardbrightnesscontrolconfig.cpp
M  +2    -0    daemon/actions/bundled/keyboardbrightnesscontrolconfig.h

https://invent.kde.org/plasma/powerdevil/commit/04815f45fe4c568e9965a1bd13ad90d2864b9906