Bug 440061 - Window decorations: drag and drop no longer properly sets title bar button preferences
Summary: Window decorations: drag and drop no longer properly sets title bar button pr...
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_kwindecoration (show other bugs)
Version: 5.22.3
Platform: Other FreeBSD
: NOR major (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-20 08:44 UTC by Graham Perrin
Modified: 2021-10-21 22:19 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen recording (3.56 MB, video/mp4)
2021-07-20 08:44 UTC, Graham Perrin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-07-20 08:44:02 UTC
Created attachment 140208 [details]
Screen recording

SUMMARY

It seems that System Settings has lost the ability to properly arrange buttons.

STEPS TO REPRODUCE

1. System Settings ▶ Appearance ▶ Window Decorations ▶ Titlebar Buttons

2. drag things in to the dummy title bar

3. drop

OBSERVED RESULT

4. a drop in the expected place

EXPECTED RESULT

4. items dropped are out of sight, or duplicated, and so on. 

SOFTWARE/OS VERSIONS

Operating System: FreeBSD 14.0
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Kernel Version: 14.0-CURRENT (64-bit)
Graphics Platform: X11
Memory: 15.9 GiB of RAM
Graphics Processor: AMD TURKS

ADDITIONAL INFORMATION

Wonder whether this broke following application of a theme, although subseqently preferring e.g. Breeze has not worked around the bug.
Comment 1 David Edmundson 2021-07-20 11:01:04 UTC
Cannot reproduce.

Please can you attach a video
Comment 2 Graham Perrin 2021-07-20 16:05:16 UTC
(In reply to David Edmundson from comment #1)

Recording attached to comment #0

Thanks
Comment 3 Nate Graham 2021-08-04 18:56:10 UTC
Also cannot reproduce.
Comment 4 raymo 2021-10-15 18:08:42 UTC
Can confirm this is an issue on 5.22.5 on Arch. The UI is oversized as well so the buttons on the right cannot be seen. https://i.imgur.com/ThHKz2C.png
Comment 5 raymo 2021-10-21 22:19:44 UTC
Looks like this was fixed on Plasma 5.23.