Bug 440036 - Allow to move a window to a single activity from the title bar menu
Summary: Allow to move a window to a single activity from the title bar menu
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: activities (show other bugs)
Version: unspecified
Platform: unspecified Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 460128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-19 12:44 UTC by Alex
Modified: 2023-01-07 02:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2021-07-19 12:44:49 UTC
SUMMARY

The activities menu in the titlebar allows to add and remove activities in which the window is visible.

A nice feature would be to allow shift-click or ctrl-click on an activity to disable all other activities and only show the window in this activity.

Another or an additional option would be to keep the menu open.

STEPS TO REPRODUCE
1. Open a window
2. Add the window to 3 of 5 activities
3. Assign it to the 4th activity and unassign it from the others

OBSERVED RESULT
You need to open the menu for each activity you want to select or deselect, which are 2 clicks per activity and moving the cursor to the right target, which can be tedious when you want to change many activities or move many windows.


EXPECTED RESULT

- Add a modifier, which allows to deselect all other activities and assign the window to the clicked activity.
- If feasible, don't close the menu after selecting/deselecting an activity (without modifier key), so one can assign/unassign more than one activity without reopening the menu.
Comment 1 Nate Graham 2022-10-10 19:02:54 UTC
*** Bug 460128 has been marked as a duplicate of this bug. ***
Comment 2 Oded Arbel 2022-11-16 11:49:42 UTC
I would also love to see this feature. I want to mention two other behaviors that are already implemented which highlight how missing this feature is:

1. kwin-wayland implemented "window on multiple desktops but not all of them", similar to how kwin always handled activities, but has added in the window operations menu - in addition to the, now multiple choice, per-desktop selection - options titles "Move to <#> <desktop name>" that do this bug description wants to do with activities.
2. On the Plasma task manager, the RMB menu's "Show in Activities" already implements the required functionality - in addition to the multiple choice activity selection, there are options for "Move to <other-activity>".
Comment 3 Zamundaaa 2023-01-03 23:28:11 UTC
Git commit 885e3712fcc7aed55d510356642db50fc0020067 by Xaver Hugl.
Committed on 03/01/2023 at 23:12.
Pushed by zamundaaa into branch 'master'.

useractions: add "Move to Activity" entries

This mirrors the menu in the task manager and makes it a lot more convenient
to send windows to the correct Activity

M  +28   -35   src/useractions.cpp
M  +0    -6    src/useractions.h

https://invent.kde.org/plasma/kwin/commit/885e3712fcc7aed55d510356642db50fc0020067
Comment 4 SP 2023-01-07 02:10:47 UTC
Thank you.