Bug 439895 - Implement KHamburgerMenu
Summary: Implement KHamburgerMenu
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 21.04.3
Platform: Other Other
: NOR normal (vote)
Target Milestone: ---
Assignee: Nate Graham
URL:
Keywords:
: 453285 459068 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-15 17:06 UTC by Podagric
Modified: 2022-11-29 19:10 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 23.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Podagric 2021-07-15 17:06:07 UTC
I just reported this to Kate so I decided to take the opportunity and register it for Konsole 😅

This implementation has already been done in other KDE apps and can be used as a reference:
Dolphin: https://invent.kde.org/system/dolphin/-/merge_requests/71
Gwenview: https://invent.kde.org/graphics/gwenview/-/merge_requests/70
KMail: https://invent.kde.org/pim/kmail/-/commit/67743a529773302fd2180c8f1a752e2534f29775
Comment 1 Nate Graham 2021-08-03 04:24:17 UTC
It's been on my to-do list. :)
Comment 2 Nate Graham 2022-05-03 16:29:01 UTC
*** Bug 453285 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-09-06 22:21:21 UTC
Working on it; see WIP work at https://invent.kde.org/utilities/konsole/-/commit/9b916a77189564771bf4a5729af1c1c2559799ea
Comment 4 Paul Worrall 2022-09-14 13:35:26 UTC
*** Bug 459068 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2022-09-24 16:08:55 UTC
A possibly relevant merge request was started @ https://invent.kde.org/utilities/konsole/-/merge_requests/743
Comment 6 Andrey 2022-11-29 19:10:57 UTC
Git commit b04265e9fa2637b58934d733aea492ced66c9e3f by Andrey Butirsky, on behalf of Nate Graham.
Committed on 29/11/2022 at 19:03.
Pushed by butirsky into branch 'master'.

Adopt KHamburgerMenu

It's amazing!
FIXED-IN: 23.04

M  +7    -2    desktop/konsoleui.rc
M  +2    -3    desktop/sessionui.rc
M  +104  -0    src/MainWindow.cpp
M  +3    -0    src/MainWindow.h
M  +1    -1    src/session/SessionController.cpp

https://invent.kde.org/utilities/konsole/commit/b04265e9fa2637b58934d733aea492ced66c9e3f