Bug 439763 - When I try to do this command:"xrandr --output DisplayPort-0 -s 1920x1080 --scale-from 3840x2160",then my whole screen looks buggy,I see my desktop in the top left corner and everything else is black.
Summary: When I try to do this command:"xrandr --output DisplayPort-0 -s 1920x1080 --s...
Status: RESOLVED DUPLICATE of bug 414866
Alias: None
Product: kwin
Classification: Unclassified
Component: xrandr (show other bugs)
Version: 5.22.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-12 00:36 UTC by Toadfield
Modified: 2021-08-03 00:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toadfield 2021-07-12 00:36:12 UTC
I tried to do this command:"xrandr --output DisplayPort-0 -s 1920x1080 --scale-from 3840x2160" but when I do this then my whole screen looks buggy,I see my desktop in the top left corner and everything else is black.

I asked somewhere else already and someone said that I should disable kscreen,but that doesn't help.

This is a kde problem,cause it doesn't happen with any other de.

Is there any workaround or fix?

This is my system info: https://i.nuuls.com/siBA7.png
Comment 1 Nate Graham 2021-08-03 00:26:38 UTC
Mixed DPIs are not supported on X11. Only Wayland explicitly supports this use case.

*** This bug has been marked as a duplicate of bug 414866 ***