Bug 439753 - Background image and album art image do not display at the same time when the image is read from a slow net disk
Summary: Background image and album art image do not display at the same time when the...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Media Player (show other bugs)
Version: master
Platform: OpenSUSE Linux
: NOR minor
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-11 11:07 UTC by Fushan Wen
Modified: 2021-08-19 19:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.23


Attachments
Phenomenon (1.18 MB, video/mp4)
2021-07-11 11:07 UTC, Fushan Wen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fushan Wen 2021-07-11 11:07:05 UTC
Created attachment 139992 [details]
Phenomenon

SUMMARY
Background image and album art image do not display at the same time when the image is read from a slow net disk (e.g. a folder mounted by rclone)

STEPS TO REPRODUCE
1. Play any music with a separated album art image in the same folder using Audacious
2. Open the media controller

OBSERVED RESULT
Background image and album art image do not display at the same time.

EXPECTED RESULT
Background image and album art image display at the same time.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210708
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-1-default (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD RENOIR

ADDITIONAL INFORMATION
Comment 1 Bug Janitor Service 2021-07-11 13:09:28 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/958
Comment 2 Nate Graham 2021-08-19 19:41:13 UTC
Git commit 95fc7e6e27cc10abc81a8f97950dd8ea6733d8ac by Nate Graham, on behalf of Fusion Future.
Committed on 19/08/2021 at 19:41.
Pushed by ngraham into branch 'master'.

[applets/mediacontroller] Ensure background image and album art image display at the same time

Background image and album art image sometimes do not display at the same
time because there are two Image instances referring to the same path, but
cache will not work because they are loaded simultaneously. Use ShaderEffect
instead of another Image instance to provide the background to fix the bug.

Use State and PropertyChanges to avoid unnecessary reevaluation of width
and height of albumArtBackground.
FIXED-IN: 5.23

M  +15   -13   applets/mediacontroller/contents/ui/ExpandedRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/95fc7e6e27cc10abc81a8f97950dd8ea6733d8ac