Bug 439651 - Hovering the mouse over "Activities" in the right click menu triggers a crash.
Summary: Hovering the mouse over "Activities" in the right click menu triggers a crash.
Status: RESOLVED DUPLICATE of bug 439877
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: master
Platform: Other Other
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
: 439721 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-08 17:24 UTC by Tony
Modified: 2021-07-19 01:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
plasmashell backtrace (3.92 KB, text/plain)
2021-07-08 17:24 UTC, Tony
Details
Demo of how to crash (652.07 KB, video/mp4)
2021-07-08 17:27 UTC, Tony
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2021-07-08 17:24:59 UTC
Created attachment 139956 [details]
plasmashell backtrace

SUMMARY
Right Clicking over a file or folder be on your desktop or Dolphin then hovering the mouse over "Activities" will trigger a crash.
It crashes plasmashell if the file/folder is located in your desktop.
Doing the same withing dolphin, will crash it but not plasmashell.

STEPS TO REPRODUCE
1. Right Click over any file/folder
2. Hover your mouse over "Activities"
3. See the sad face pop.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: opensuse Tumbleweed
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
It happens in both session, wayland/x11.
Can't get a backtrace from Dolphin since it does not dump and valgrind does not work.
Can trigger it everytime.
Comment 1 Tony 2021-07-08 17:27:19 UTC
Created attachment 139957 [details]
Demo of how to crash
Comment 2 Tony 2021-07-11 00:39:56 UTC
From the journalctl -ex i get this doing the same in dolphin :

Jul 10 20:37:54 joder-pc plasmashell[16047]: file:///usr/lib64/qt5/qml/org/kde/plasma/components/ModelContextMenu.qml:38:1: QML ModelContextMenu: Accessible must be attached to an Item
Jul 10 20:37:57 joder-pc plasmashell[16152]: KCrash: Application 'dolphin' crashing...
Jul 10 20:37:57 joder-pc dolphin[16152]: The Wayland connection experienced a fatal error: Bad file descriptor
Jul 10 20:37:57 joder-pc systemd[13590]: app-org.kde.dolphin-2fb45fb82a6d4d29876911a06921f417.scope: Deactivated successfully.
Comment 3 Kai Uwe Broulik 2021-07-12 20:05:25 UTC
Can confirm, just witnessed the same, albeit with a different backtrace.

Thread 1 (Thread 0x7fcd41d81700 (LWP 428697)):
[KCrash Handler]
#3  std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=<optimized out>) at /usr/include/c++/9/bits/atomic_base.h:413
#4  QAtomicOps<int>::loadRelaxed<int> (_q_value=...) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic_cxx11.h:239
#5  QBasicAtomicInteger<int>::loadRelaxed (this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qbasicatomic.h:107
#6  QtPrivate::RefCount::ref (this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qrefcount.h:55
#7  QString::QString (other=..., this=0x7fcd41d80ac0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qstring.h:1094
#8  QStringBuilder<QString, QString>::operator QString (this=<synthetic pointer>, this=<synthetic pointer>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qstringbuilder.h:147
#9  FileItemLinkingPluginActionLoader::run (this=0x5633a171dbf0) at ./activities/fileitemplugin/FileItemLinkingPluginActionLoader.cpp:77
#10 0x00007fcd92821dbc in QThreadPrivate::start (arg=0x5633a171dbf0) at thread/qthread_unix.cpp:329
#11 0x00007fcd90f66609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#12 0x00007fcd924a2293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
Comment 4 Tony 2021-07-12 23:43:21 UTC
(In reply to Kai Uwe Broulik from comment #3)
> Can confirm, just witnessed the same, albeit with a different backtrace.
> 
> Thread 1 (Thread 0x7fcd41d81700 (LWP 428697)):
> [KCrash Handler]
> #3  std::__atomic_base<int>::load (__m=std::memory_order_relaxed,
> this=<optimized out>) at /usr/include/c++/9/bits/atomic_base.h:413
> #4  QAtomicOps<int>::loadRelaxed<int> (_q_value=...) at
> /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic_cxx11.h:239
> #5  QBasicAtomicInteger<int>::loadRelaxed (this=<optimized out>) at
> /usr/include/x86_64-linux-gnu/qt5/QtCore/qbasicatomic.h:107
> #6  QtPrivate::RefCount::ref (this=<optimized out>) at
> /usr/include/x86_64-linux-gnu/qt5/QtCore/qrefcount.h:55
> #7  QString::QString (other=..., this=0x7fcd41d80ac0) at
> /usr/include/x86_64-linux-gnu/qt5/QtCore/qstring.h:1094
> #8  QStringBuilder<QString, QString>::operator QString (this=<synthetic
> pointer>, this=<synthetic pointer>) at
> /usr/include/x86_64-linux-gnu/qt5/QtCore/qstringbuilder.h:147
> #9  FileItemLinkingPluginActionLoader::run (this=0x5633a171dbf0) at
> ./activities/fileitemplugin/FileItemLinkingPluginActionLoader.cpp:77
> #10 0x00007fcd92821dbc in QThreadPrivate::start (arg=0x5633a171dbf0) at
> thread/qthread_unix.cpp:329
> #11 0x00007fcd90f66609 in start_thread (arg=<optimized out>) at
> pthread_create.c:477
> #12 0x00007fcd924a2293 in clone () at
> ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

You are getting the same backtrace as 439721
Duplicate?
Comment 5 Tony 2021-07-16 20:38:51 UTC
*** Bug 439721 has been marked as a duplicate of this bug. ***
Comment 6 Tony 2021-07-17 02:29:53 UTC
Is master there is no more crashing, the activities list now just don't load up.
Comment 7 Tony 2021-07-19 01:52:27 UTC

*** This bug has been marked as a duplicate of bug 439877 ***