Bug 439503 - systemmonitor crashes
Summary: systemmonitor crashes
Status: RESOLVED DOWNSTREAM
Alias: None
Product: plasma-systemmonitor
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-05 06:25 UTC by Bernd Kaiser
Modified: 2021-07-29 13:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Kaiser 2021-07-05 06:25:22 UTC
SUMMARY


STEPS TO REPRODUCE
1. open systemmonitor
2. monitor opens
3. after5seconds w/o doing anything it closes

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 David Redondo 2021-07-05 06:57:13 UTC
Hi could you provide a backtrace, otherwise we are not able to know what's going wrong 
https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
Comment 2 Bug Janitor Service 2021-07-20 04:33:35 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Iván Ávalos 2021-07-24 04:21:38 UTC
I'm having the same problem in Parabola GNU/Linux (Arch-based) using the latest version (5.22.3). It exits normally, immediately, but plasma-systemmonitor never starts. Here's a GDB backtrace:

GNU gdb (GDB) 10.2
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from plasma-systemmonitor...
(No debugging symbols found in plasma-systemmonitor)
(gdb) run
Starting program: /usr/bin/plasma-systemmonitor 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7ffff0f8b640 (LWP 164876)]
[New Thread 0x7fffebf78640 (LWP 164877)]
[Thread 0x7fffebf78640 (LWP 164877) exited]
[Thread 0x7ffff14aaa80 (LWP 164872) exited]
[Inferior 1 (process 164872) exited normally]
(gdb) bt
No stack.
(gdb) quit

Here's the related issue on Parabola's bug tracker:
https://labs.parabola.nu/issues/3057
Comment 4 David Redondo 2021-07-29 13:37:31 UTC
From the linked bug report, looks like libksysguard is out of date