Bug 439375 - The font management kcm is missing from system settings in wayland session
Summary: The font management kcm is missing from system settings in wayland session
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_fontinst (show other bugs)
Version: 5.22.2
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Edmundson
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-07-01 14:08 UTC by Ondřej Růžička
Modified: 2022-01-11 03:19 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
systemsettings screenshot form wayland session (20.10 KB, image/png)
2021-07-01 14:08 UTC, Ondřej Růžička
Details
systemsettings screenshot from X session (22.58 KB, image/png)
2021-07-01 14:08 UTC, Ondřej Růžička
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondřej Růžička 2021-07-01 14:08:11 UTC
Created attachment 139784 [details]
systemsettings screenshot form wayland session

SUMMARY
The font management kcm is nowhere to be found in system settings in wayland session
That also blocks installing fonts

STEPS TO REPRODUCE
1. open system settings
2. navigate to appearance>fonts management

OBSERVED RESULT
Nothing like fonts management is present

EXPECTED RESULT
Finding font management module

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210628
KDE Plasma Version: 5.22.2
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Kernel Version: 5.12.13-1-default (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-7300U CPU @ 2.60GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 620

ADDITIONAL INFORMATION
Works just fine in X11 session
Comment 1 Ondřej Růžička 2021-07-01 14:08:55 UTC
Created attachment 139785 [details]
systemsettings screenshot from X session
Comment 2 Nate Graham 2021-07-29 19:27:07 UTC
Yeah it's not yet supported on Wayland. We can use this bug report to track making it compatible. Added it to https://community.kde.org/Plasma/Wayland_Showstoppers
Comment 3 Petros 2021-09-26 16:17:00 UTC
I have just tried plasma wayland and it seems Fonts are present, visible and usable.

I have installed sddm-wayland-git and enabled wayland on sddm (although I have not confirmed yet it really runs on it). I think Fonts were working, even before this, but my memory is not strong enough...

Operating System: Arch Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.7-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
Memory: 6.7 GiB of RAM
Graphics Processor: AMD Radeon™ Vega 8 Graphics
Comment 4 David Edmundson 2021-09-26 19:53:14 UTC
>I think Fonts were working, even before this, but my memory is not strong enough...

Font selection is, font installation is not.

It was lazily disabled. It needs fixing.
Comment 5 Patrick Silva 2021-12-13 12:49:19 UTC
Font Management KCM is present on Wayland session of neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 6 Nate Graham 2021-12-13 19:17:42 UTC
Looks like the recent JSON porting caused the "this KCM is Wayland only" thing in the desktop files to get broken.
Comment 7 Bug Janitor Service 2021-12-14 07:45:42 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/systemsettings/-/merge_requests/104
Comment 8 Alexander Lohnau 2021-12-14 09:37:08 UTC
Git commit 24ef056891784924047b24fad629469621cfab88 by Alexander Lohnau.
Committed on 14/12/2021 at 09:29.
Pushed by alex into branch 'master'.

Respect X-KDE-OnlyShowOnQtPlatforms setting when querying KCMs

KServiceTypeTrader took care of this behind the scenes.
Because of that we need to manually check the values when querying the plugins.

Needs https://invent.kde.org/plasma/plasma-workspace/-/commit/0a1cc4b62498ff532f7d7fff2ebb1ef4ae096a94 and https://invent.kde.org/plasma/kinfocenter/-/commit/01c039cdf71a3e3e828443e8e2a1d3ff525ed18a.

M  +11   -4    core/kcmmetadatahelpers.h

https://invent.kde.org/plasma/systemsettings/commit/24ef056891784924047b24fad629469621cfab88
Comment 9 Nate Graham 2021-12-24 14:54:00 UTC
This will be fixed by https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1279
Comment 10 Nate Graham 2022-01-11 03:19:22 UTC
Git commit 6f5a28665cd8ac27fd02b97d71da4a5f183e2959 by Nate Graham, on behalf of David Edmundson.
Committed on 11/01/2022 at 03:18.
Pushed by ngraham into branch 'master'.

[kcms/kfontinst] Re-enable on wayland

The entire KCM was diabled due to crashes:
Since c305dcd85dc718a9c5f832fa8e56ca291f8044be the relevant
section is disabled instead of crashing. This allows us to reintroduce
the KCM, albeit with previews currently disabled.
FIXED-IN: 5.24

M  +0    -3    kcms/kfontinst/kcmfontinst/fontinst.json

https://invent.kde.org/plasma/plasma-workspace/commit/6f5a28665cd8ac27fd02b97d71da4a5f183e2959