Bug 439040 - Some strings in right click menus of input fields are not localized (Undo/Redo/Cut/Copy/Paste/Delete)
Summary: Some strings in right click menus of input fields are not localized (Undo/Red...
Status: RESOLVED DOWNSTREAM
Alias: None
Product: frameworks-ki18n
Classification: Unclassified
Component: general (show other bugs)
Version: 5.83.0
Platform: Exherbo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Chusslove Illich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-22 22:38 UTC by Timo Gurr
Modified: 2021-08-11 11:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kfind.png (47.99 KB, image/png)
2021-06-22 22:38 UTC, Timo Gurr
Details
dolphin.png (26.99 KB, image/png)
2021-06-22 22:38 UTC, Timo Gurr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Gurr 2021-06-22 22:38:00 UTC
Created attachment 139596 [details]
kfind.png

SUMMARY
I hope I chose the right component. Some strings in right click menus of input fields are not localized, like e.g. Undo/Redo/Cut/Copy/Paste/Delete. See attached screenshots.


STEPS TO REPRODUCE (kfind)
1. open kfind
2. right click any text input field

STEPS TO REPRODUCE (dolphin)
1. right click a file to rename it and see proper translated strings
2. right click in the highlighted input where you can type the filename and see untranslated strings


EXPECTED RESULT
Have everything properly localized.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.22.1
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
I can also reproduce this behaviour on a current up-to-date Fedora 34 KDE Plasma Session so this is not exclusive to Exherbo Linux.

Everything else is properly localized, so I assume no user configuration error on my side.

$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Plasma is also setup with the proper non-english localization via systemsettings kcm.
Comment 1 Timo Gurr 2021-06-22 22:38:18 UTC
Created attachment 139597 [details]
dolphin.png
Comment 2 geisserml 2021-08-10 20:17:41 UTC
How strange. For me these strings are localised correctly (Plasma 5.22.4 / KDE Neon). When you installed your distribution, did you already choose German, or have you changed the system language afterwards? If the latter is the case, it might be caused by a missing locale package, perhaps.
Comment 3 geisserml 2021-08-10 20:22:41 UTC
The peculiar thing is that only the simple strings like undo/redo/cut/paste/... are not translated. Looks somehow like missing QtBase locale to me. Could you check whether more Qt-based programs than just Dolphin and KFind are affected, please?
Comment 4 geisserml 2021-08-10 20:25:10 UTC
Would you paste or attach the ouput of `ls /usr/share/qt5/translations`, please?
Comment 5 geisserml 2021-08-10 20:28:06 UTC
*output
If `qtbase_de.qm` is missing, then we may have found the cause.
Comment 6 Timo Gurr 2021-08-10 20:53:01 UTC
(In reply to Manuel Geißer from comment #5)
> *output
> If `qtbase_de.qm` is missing, then we may have found the cause.

Indeed! Huge thanks for that very insightful hint. Now I was just wondering that I couldn't find any translation sources included in the qtbase source tarball at all and just found out it's shipped in a separate tarball/package "qttranslations" which solves my problem with the missing files and of course also the inital problem I had. Again thanks and sorry for the noise, I'll see that I can add a suggestion/recommendation on qttranslations to our qtbase package to make things more obvious.
Comment 7 Timo Gurr 2021-08-10 21:21:46 UTC
FYI: The same problem/solution exists on Fedora, might have to verify with a complete fresh installation, but on an else localized KDE Plasma desktop pre-installed via the "KDE Spin" the "qt5-qtranslations" package was missing there as well.
Comment 8 geisserml 2021-08-11 11:12:14 UTC
Nice!
I think on KDE Neon the package is named `qttranslations5-l10n`.