Bug 438811 - Scrolling over taskbar does not restore minimized windows in Plasma 5.22
Summary: Scrolling over taskbar does not restore minimized windows in Plasma 5.22
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.22.1
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-06-17 15:54 UTC by Maximilian Böhm
Modified: 2022-04-26 13:27 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maximilian Böhm 2021-06-17 15:54:09 UTC
Before this release, I was able to scroll over the taskbar to restore minimized windows. This was a convenient way to restore windows rather than have to exactly point on the entries and click. With plasma 5.22.x, this no longer works.

Arch Linux
KDE Plasma Version:  5.22.1
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-06-17 18:09:43 UTC
Another intentional change that I suspected people would complain about. See Bug 426722.

We can either make it configurable to let people optionally use the old way, or say that this is the way it's gonna always be now.

Bharadwaj, what are your thoughts?
Comment 2 Bharadwaj Raju 2021-06-17 18:22:09 UTC
I'd say Abhijeet Viswa is the person to ask as he implemented it. But it seems like the kind of stuff we can make configurable with not much maintenance impact.
Comment 3 Nate Graham 2021-07-23 21:45:28 UTC
Oops, sorry!
Comment 4 rjx_ 2021-07-28 09:00:26 UTC
Having an option to enable scrolling over all the windows in taskbar irregardless of min/maximized status would be pretty nice.
It's quite cumbersome to always aim for the right task's tab with your mouse and then clicking on it instead of just bringing cursor all the way down and scrolling through them all quickly.
I used it like kind of a faster/easier alt-tab task switcher, and now it's somewhat broken (i can minimize windows without realizing it, default breeze's theme got fairly subtle/barely noticeable minimization indicator bar on top), hence at least making it configurable for people with similar workflows like mine would be much appreciated.
Comment 5 Maximilian Böhm 2022-02-12 22:27:40 UTC
Does not look like this request got any attention recently, sadly. How can we reach Abhijeet?
Comment 6 Abhijeet Viswa 2022-02-13 06:11:41 UTC
Hi, I guess I missed this thread in my inbox. 
The original MR I made actually did have an option to disable the feature so that existing workflows wouldn't get affected. However, some folk mentioned that wouldn't be required and that skipping minimized tasks was the more sane option: https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/154#note_107881

@Nate should I go ahead and create an MR? Like Bhardwaj said, I don't see any long term negative impacts of giving users a choice.
Comment 7 Nate Graham 2022-02-14 17:56:29 UTC
Sure, go ahead and submit one.
Comment 8 Maximilian Böhm 2022-02-14 21:11:42 UTC
Highly appreciated, thx!
Comment 9 Abhijeet Viswa 2022-04-09 18:35:32 UTC
Hi, sorry for the huge delay. I had other work and couldn't get to this. 
I've opened an MR to fix this: https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/899
The soft feature freeze for 5.25 was a while back. But hopefully this minor change can be squeezed for the release.
Comment 10 Nate Graham 2022-04-09 19:26:56 UTC
FWIW the soft feature freeze is in almost a month, on 5 March. See https://community.kde.org/Schedules/Plasma_5#Future_releases. So there's still plenty of time.

Thanks for working on this! I will review in the next few days, if nobody else gets to it first.
Comment 11 Nate Graham 2022-04-26 13:27:02 UTC
Git commit 4846fb80a71e17469a32494fe38636f80de06211 by Nate Graham, on behalf of Abhijeet Viswa.
Committed on 26/04/2022 at 13:26.
Pushed by ngraham into branch 'master'.

applets/taskmanager: Add setting to skip minimized tasks when switching by scrolling

1e546f4efd036acf20813acb5b11dda7f486167f changed the Task Manager so that
minimized tasks inside and outside tasks groups are skipped when switching
by scrolling. However, this change wasn't toggleable and enforced on the
user.

This commit provides a toggle that can be used to skip minimized tasks.
The default for this option is 'True' i.e to skip options. The use has
to explicitly disable this behaviour, since users might have already
gotten used to the new behaviour.
FIXED-IN: 5.25

M  +4    -0    applets/taskmanager/package/contents/config/main.xml
M  +12   -0    applets/taskmanager/package/contents/ui/ConfigBehavior.qml
M  +3    -2    applets/taskmanager/package/contents/ui/code/tools.js

https://invent.kde.org/plasma/plasma-desktop/commit/4846fb80a71e17469a32494fe38636f80de06211