Bug 438600 - [Unattended updates] System reboots but updates don't get installed
Summary: [Unattended updates] System reboots but updates don't get installed
Status: RESOLVED DUPLICATE of bug 438809
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (offline) (show other bugs)
Version: 5.22.0
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-14 08:43 UTC by MK
Modified: 2021-06-18 13:43 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Discover notifying about non-existent updates (225.67 KB, application/pdf)
2021-06-16 07:53 UTC, MK
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MK 2021-06-14 08:43:31 UTC
SUMMARY
Since Plasma 5.22 unattended updates appear to be broken as per summary description.

STEPS TO REPRODUCE
1. Wait for updates to be downloaded
2. Allow Discover to reboot machine
3. Machine reboots but no update occurs

OBSERVED RESULT
No update at reboot time

EXPECTED RESULT
Updates applied at reboot

SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.22
KDE Plasma Version: 5.22.0
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.3
Kernel Version: 5.4.0-74-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-6200U CPU @ 2.30GHz
Memory: 7.1 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520

ADDITIONAL INFORMATION
Comment 1 tagwerk19 2021-06-14 20:50:21 UTC
Also seen this. Not every time, but enough to confuse.

After you reboot and log back in, you get a "pop up" with the same number of patches needing to be applied. If you run Discover again and update all, you get the "restart" prompt straight away and then the patches are applied.
Comment 2 Nate Graham 2021-06-15 21:36:02 UTC
Weird.
Comment 3 MK 2021-06-16 07:53:21 UTC
Created attachment 139371 [details]
Discover notifying about non-existent updates
Comment 4 MK 2021-06-16 07:54:26 UTC
(In reply to Antanicus from comment #3)
> Created attachment 139371 [details]
> Discover notifying about non-existent updates

Updates were correctly applied this morning (ie. at reboot time) but after logging in I was notified about new updates, but there seems to be nothing to update.
Comment 5 Nate Graham 2021-06-16 15:08:01 UTC

*** This bug has been marked as a duplicate of bug 438670 ***
Comment 6 Nate Graham 2021-06-18 13:43:03 UTC

*** This bug has been marked as a duplicate of bug 438809 ***