Bug 438536 - Using right click on a Desktop icon will show the context menu on the other monitor
Summary: Using right click on a Desktop icon will show the context menu on the other m...
Status: RESOLVED UPSTREAM
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL: https://bugreports.qt.io/browse/QTBUG...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-13 07:41 UTC by fuomag
Modified: 2022-03-13 21:53 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
This shows the context menu opening on the other monitor (1.05 MB, image/png)
2021-06-13 07:41 UTC, fuomag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fuomag 2021-06-13 07:41:50 UTC
Created attachment 139276 [details]
This shows the context menu opening on the other monitor

SUMMARY

Using right click on a Desktop icon will show the context menu on the other monitor in the same position instead of the right one


STEPS TO REPRODUCE
1. use two monitors
2. set the primary monitor to the one on the right
3. right click on an icon on the desktop
4. the context menu will open in the right position but in the other monitor

OBSERVED RESULT

the context menu will open in the right position but in the other monitor


EXPECTED RESULT

the context menu should open in the monitor the click is made

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: fedora 34
(available in About System)
KDE Plasma Version: 5.21.5-3
KDE Frameworks Version: 5.82.0
Qt Version: 5.12.2

ADDITIONAL INFORMATION
Comment 1 Kan 2021-06-14 16:31:30 UTC
I too am having this issue. My issue mirrors the OP's original steps to reproduce. 

Operating System: EndeavourOS
KDE Plasma Version: 5.22.0
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Kernel Version: 5.12.10-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 6 × Intel® Core™ i5-9600K CPU @ 3.70GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
Comment 2 Nate Graham 2021-06-15 21:03:15 UTC
This is an upstream Qt issue: https://bugreports.qt.io/browse/QTBUG-85297
Comment 3 fuomag 2021-06-24 19:51:22 UTC
Relevant upstream issue for X11 https://bugreports.qt.io/browse/QTBUG-94778
Comment 4 fuomag 2021-07-05 07:39:57 UTC
Interestingly enough this bug does NOT happen on kubuntu 21.04 with Qt 5.15.2. Here are the software versions:

Operating System: Kubuntu 21.04
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-22-generic
OS Type: 64-bit
Graphics Platform: X11


Are we sure it's an upstream issue and not a KDE Plasma/Frameworks one?
Comment 5 Christian Finnberg 2021-07-06 07:14:37 UTC
This bug is marked as resolved upstream, but actually it is not resolved. Yes, it seems to be a QT bug, but also they seem to be unable to fix this without the help of someone from KDE's part: https://bugreports.qt.io/browse/QTBUG-94778?focusedCommentId=574767&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-574767
Comment 6 Nate Graham 2021-07-06 17:24:06 UTC
See https://community.kde.org/Get_Involved/Issue_Reporting#Understand_what_the_resolution_statuses_mean

If you want to ping KDE developers, you can do it in the upstream bug report (https://bugreports.qt.io/browse/QTBUG-85297).
Comment 7 Eric Putney 2021-08-07 14:15:41 UTC
I see that this issue has to do with Qt and/or X11, but here's an interesting detail on this bug's behavior. I have two monitors of different sizes, my primary (right) monitor is 3440x1440, my left monitor is 2560x1440. Right-clicking anywhere on my primary monitor makes the context menu appear exactly 2560 pixels to the left of where I clicked, so it's using the horizontal size of my left non-primary monitor as the offset. The only reason why the context menu has been showing up in the "right place" on a different monitor is because most people have the same sized monitor, so the offset moves it by exactly one monitor's length. If I right click an icon on the far right side of my right monitor, it opens on the same monitor but way on the left side (2560 pixels to the left). I hope this helps someone somewhere with the debugging process.

Also this is my first post, I clicked something in the status dropdown menu but I'm not really sure how that works. Apologies if I accidentally changed the                     bug status.
Comment 8 CRhodes 2021-09-27 08:11:09 UTC
This was marked as resolved upstream but no details as to where, i checked the links to the qt and x11 bugs both of which are unresolved. I too am having the issue with Manjaro with the following software versions:
KDE plasma 5.22.5
KDE Frameworks 5.86.0
QT 5.15.2
Kernal 5.13.19-2-Manjaro (64bit)
X11
2 x 1440p monitors with my right one as the primary. This doesn't happen when left is primary or if you right click on the desktop, only when you right click on an icon on the desktop.
Comment 9 CRhodes 2021-09-27 08:13:15 UTC
I get how this works now, sorry, re marked as resolved upstream as the bugs have been reported upstream.