Bug 438401 - [Wayland] 3rd-party window decoration pixelatex/badly rendered when fractional display scaling is used
Summary: [Wayland] 3rd-party window decoration pixelatex/badly rendered when fractiona...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: aurorae (show other bugs)
Version: unspecified
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-06-10 11:45 UTC by Patrick Silva
Modified: 2024-05-13 01:25 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (121.01 KB, image/png)
2021-06-10 11:45 UTC, Patrick Silva
Details
Screenshot of monitor scaled at 100% (87.40 KB, image/png)
2021-10-21 11:55 UTC, Tim
Details
Screenshot of monitor scaled at 125% (159.70 KB, image/png)
2021-10-21 11:56 UTC, Tim
Details
screenshot (167.55 KB, image/png)
2021-12-09 00:39 UTC, Patrick Silva
Details
Settings fonts page - 125% scaling (138.11 KB, image/png)
2021-12-19 00:17 UTC, Tim
Details
screenshot (248.40 KB, image/png)
2023-02-15 23:40 UTC, rsm_questioning
Details
screenshot, multimonitor secondary screen at 150% (444.09 KB, image/png)
2024-05-13 01:25 UTC, iris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-06-10 11:45:15 UTC
Created attachment 139188 [details]
screenshot

STEPS TO REPRODUCE
1. install WhiteSur window decorations from KDE Store
2. set WhiteSur window decoration
3. set display scale to 125% in Display Configuration KCM

OBSERVED RESULT
as we can see in the attached screenshot, fonts of the window title are badly rendered

EXPECTED RESULT
correctly rendered fonts

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 1 Tim 2021-10-21 11:55:57 UTC
Created attachment 142721 [details]
Screenshot of monitor scaled at 100%
Comment 2 Tim 2021-10-21 11:56:23 UTC
Created attachment 142722 [details]
Screenshot of monitor scaled at 125%
Comment 3 Tim 2021-10-21 11:56:38 UTC
I have the same problem using Garuda Linux, which uses Sweet Dark window decorations at any scaling above 100%

STEPS TO REPRODUCE
1. Set monitor scaling to >100%

OBSERVED RESULT
Window titles are no longer rendered correctly (see attached screenshots).

EXPECTED RESULT
Fonts scale correctly and remain readable

SOFTWARE/OS VERSIONS
Operating System: Garuda Linux
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 4 Méven Car 2021-12-08 11:29:36 UTC
I don't reproduce this with default breeze at 1.25 scale, it is affected by https://bugs.kde.org/show_bug.cgi?id=446674 though.

What is your titlebar font size?

It seems to be smaller than the default one.
Comment 5 Patrick Silva 2021-12-09 00:39:58 UTC
Created attachment 144372 [details]
screenshot

Possibly it was bold font. But, as we can see in the screenshot attached to this
comment, the bug also occurs with default noto sans 10pt font.
Comment 6 Nate Graham 2021-12-09 17:07:15 UTC
Seems like it's not just the font but rather the entire Aurorae window decoration that's pixelated.
Comment 7 Tim 2021-12-19 00:17:00 UTC
Created attachment 144666 [details]
Settings fonts page - 125% scaling

I get similar results here. Looks like the entire window decoration is pixelated when scaled.
Comment 8 kfsbgd4o48tf 2022-08-03 18:47:34 UTC
Can confirm on 5.25.3 wayland. Many Aurorae themes other than breeze are affected. https://github.com/PapirusDevelopmentTeam/materia-kde/issues/143
Comment 9 postix 2022-08-03 19:25:50 UTC
Question for those who currently use the master version of KWin: Is this fixed by https://invent.kde.org/plasma/kwin/-/merge_requests/2456 ?
Comment 10 David Edmundson 2022-08-03 21:42:46 UTC
It probably won't have any impact here I'm afraid.
Comment 11 Patrick Silva 2022-08-04 12:03:34 UTC
The bug persists on neon unstable.
Comment 12 Kanwar Plaha 2022-10-29 03:58:31 UTC
Can confirm this is still manifesting on OpenSUSE Tumbleweed with KDE Plasma 5.26.1 / Framework 5.99.0 and Qt 5.15.6.
Comment 13 farline99 2022-11-02 10:13:36 UTC
I still see this problem with scaling 200% at a resolution of 2736x1824. 

SOFTWARE/OS VERSIONS
---
Operating System: Arch Linux 
KDE Plasma Version: 5.26.2
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Graphics Platform: Wayland
---

P.S.
Please pay attention to this problem, it's a shame to lose the ability to change the window frame simply because of fonts. All the charm of KDE Plasma goes out.
Comment 14 rsm_questioning 2023-02-15 23:40:06 UTC
Created attachment 156284 [details]
screenshot

I'm facing the same issue on Fedora Linux 37 Kinoite.

KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.8
Kernel Version: 6.1.9-200.fc37

Using a custom theme
Comment 15 farline99 2023-02-17 22:42:21 UTC
Same here with Arch Linux, Plasma 5.27, frameworks 103, Wayland, 200℅ scaling. Using custom theme from vinceliuice.
Comment 16 Mathias Tillman 2023-03-02 09:18:08 UTC
Was this fixed in one of the 5.27.X releases? It seems to work fine for me now on 5.27.2 anyhow.
Comment 17 Vlad Zahorodnii 2023-03-02 09:31:47 UTC
It was.
Comment 18 farline99 2023-03-02 09:49:31 UTC
Oh yeah, it is fixed!!! Thank you, KDE 😍❤️
Comment 19 iris 2024-05-13 01:25:43 UTC
Created attachment 169417 [details]
screenshot, multimonitor secondary screen at 150%

Still seeing font pixelation on aurorae window decoration title with a multi monitor setup, setup as follows

STEPS TO REPRODUCE
- Set primary monitor (1920 x 1200) display configuration to 100% scaling
- Set secondary monitor (2256 x 1504) display configuration to 150% scaling
- Install Chameleon Dark window decoration theme (note I am running a modified version of it but have also replicated on the public version as well as Ant Dark and Commonality decorations)

OBSERVED RESULT
- Window decoration title fonts on secondary monitor are pixelated (see screenshot)

EXPECTED RESULT
- Window decoration title fonts should be correctly scaled and non pixelated

SOFTWARE/OS VERSIONS
Operating System: KDE neon 6.0
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Graphics Platform: Wayland