Bug 438321 - Some icons in the hovering tooltip do not match the ones in the side panel
Summary: Some icons in the hovering tooltip do not match the ones in the side panel
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.21.5
Platform: Other Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2021-06-09 11:55 UTC by Apoorv Potnis
Modified: 2021-08-23 19:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Apoorv Potnis 2021-06-09 11:55:14 UTC
SUMMARY

The icons of Hardware Configuration, Removable Storage and Systemd in the side panel of Manjaro System Settings are monochrome while others are coloured. When on these settings, the tooltip box shows the correct, coloured icons. Correct icons are shown in tooltip boxes for other settings.

STEPS TO REPRODUCE
1. Open System Settings
2. Hover on the settings on the left side panel. 

System details:
OS: Manjaro 21.0.5 Ornara
DE: KDE 5.82.0 / Plasma 5.21.5
Resolution: 1920x1080
WM Theme: Breeze
Theme: Breeze Light [Plasma], Breeze [GTK2/3]
Icons: breeze [Plasma], breeze [GTK2/3]
Comment 1 Nate Graham 2021-06-09 23:06:26 UTC
This is because the icons are shown at different sizes between the two; the list items show 22px icons, while the tooltip shows a 32px icon. For icons that have different appearances between these sizes, the bug can happen.

Possible solutions:
1. Use 22px icon size in the tooltip as well
2. Change affected KCMs to use icons that don't have monochrome 22px versions, making whatever changes are needed to icons to make this posible

Good junior job possibility. :)
Comment 2 Nate Graham 2021-08-23 19:16:54 UTC
Option 1 was eventually done.