Bug 438280 - default locale should be C.UTF-8, not C
Summary: default locale should be C.UTF-8, not C
Status: RESOLVED DUPLICATE of bug 394698
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_formats (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-08 18:16 UTC by Jonas
Modified: 2021-06-08 19:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas 2021-06-08 18:16:21 UTC
As title says. In any case, C.UTF-8 should be an option. Why should I have to have to select from a list of nation-states just to get reasonable defaults?

I'm using kubuntu 20.04. I can't tell you which KDE version since it's not shown in the "About KDE" dialog anymore (why?)
Comment 1 Nate Graham 2021-06-08 18:43:58 UTC
The default locale is selected by the distro, not by us.

The usability improvement of being to simply directly select what you want (OMG yes please) is tracked by Bug 394698; marking as a duplicate of it as that is the only actionable part of this bug report.

*** This bug has been marked as a duplicate of bug 394698 ***
Comment 2 Jonas 2021-06-08 19:52:01 UTC
OK but what about C.UTF-8 being an option in the dropdown menu?

For me, the first entry in the menu is "Default (C)", and "C.UTF-8" is not in the menu as far as I can see. Maybe I wasn't very clear, but the feature that I would like to see at least, is to have "C.UTF-8" available in the menu additionally (if not as a replacement of "C").

I don't think the suggestion of having the option of "C.UTF-8" in the dropdown is a duplicate of the bug you linked. If you want I can add a new bug report that's more clear.
Comment 3 Nate Graham 2021-06-08 19:59:55 UTC
Yes please. This is why bug reports that report multiple issues/requests are discouraged. :)