Bug 438017 - Drawer generates a thin line on its window edge that consumes clicks without triggering any action
Summary: Drawer generates a thin line on its window edge that consumes clicks without ...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Unclassified
Component: general (show other bugs)
Version: 5.85.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: usability
: 442211 447944 450231 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-06-02 23:22 UTC by medin
Modified: 2022-02-17 15:28 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.92


Attachments
A part of hamburger menu button consumes clicks without triggering any action (113.79 KB, image/png)
2021-06-02 23:22 UTC, medin
Details
can't reproduce (1.97 MB, image/gif)
2021-06-05 01:55 UTC, trmdi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medin 2021-06-02 23:22:54 UTC
Created attachment 138965 [details]
A part of hamburger menu button consumes clicks without triggering any action

See attached image for more info.
Comment 1 trmdi 2021-06-05 01:55:22 UTC
Created attachment 139011 [details]
can't reproduce

I can't reproduce it.
Comment 2 medin 2021-06-05 10:52:29 UTC
(In reply to trmdi from comment #1)
> Created attachment 139011 [details]
> can't reproduce
> 
> I can't reproduce it.

I don't think it's 21.04.0 ?
Comment 3 trmdi 2021-06-05 10:58:10 UTC
(In reply to medin from comment #2)
> (In reply to trmdi from comment #1)
> > Created attachment 139011 [details]
> > can't reproduce
> > 
> > I can't reproduce it.
> 
> I don't think it's 21.04.0 ?

Ah yes, it's the git version. Can you try it?
Comment 4 Nate Graham 2021-06-09 16:20:44 UTC
I can reproduce the issue.
Comment 5 Nate Graham 2021-06-09 16:22:27 UTC
In fact there seems do be a dead zone for all UI controls on the right-hand side of the window.
Comment 6 Nate Graham 2021-06-09 16:24:52 UTC
Seems to be an Elisa-specific issue as I cannot reproduce it with other apps--Kirigami or QTWidgets alike.
Comment 7 Nate Graham 2021-06-09 16:26:52 UTC
git bisect back to January doesn't reveal anything; looks like this has been the case for quite a while.
Comment 8 trmdi 2021-06-10 11:36:03 UTC
Ah found it. Something relates to the context drawer. Do we need it on the desktop?
Comment 9 Nate Graham 2021-06-10 15:35:07 UTC
That would make sense. It's used when the window is very narrow, so allow the playlist to collapse and become a drawer. But with the new mobile UI, I wonder how much we actually need it.

In fact--and this is kind of a radical idea, I know--I wonder if we could move in the direction of only using the mobile UI, and polishing it up a tiny bit for the desktop use case. It's really good, and it works really well as a desktop app when the window is quite large.
Comment 10 Nate Graham 2021-09-02 16:34:53 UTC
This is a Kirigami bug, caused by the invisible drag area for the drawer.
Comment 11 Nate Graham 2021-09-09 17:40:00 UTC
*** Bug 442211 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2022-01-12 20:11:51 UTC
*** Bug 447944 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2022-02-16 01:29:25 UTC
*** Bug 450231 has been marked as a duplicate of this bug. ***
Comment 14 trmdi 2022-02-16 15:23:56 UTC
(In reply to Nate Graham from comment #10)
> This is a Kirigami bug, caused by the invisible drag area for the drawer.

Or it is just a bug in Elisa? Since that area is needed for triggering the swipe event.
Comment 15 Bug Janitor Service 2022-02-16 15:45:41 UTC
A possibly relevant merge request was started @ https://invent.kde.org/multimedia/elisa/-/merge_requests/326
Comment 16 Nate Graham 2022-02-16 15:53:49 UTC
It's a generic issue in any app that implements a drawer. Any fix should ideally be made in Kirigami itself, not in each and every app that uses it.
Comment 17 Bug Janitor Service 2022-02-16 16:52:13 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/495
Comment 18 Nate Graham 2022-02-17 15:27:26 UTC
Git commit 778e3be51bc4295c1a55f8c7a8c81498988c2a44 by Nate Graham, on behalf of Tranter Madi.
Committed on 17/02/2022 at 15:18.
Pushed by ngraham into branch 'master'.

Drawer should not eat mouse events at edges

M  +1    -0    src/controls/GlobalDrawer.qml
M  +1    -0    src/controls/OverlayDrawer.qml

https://invent.kde.org/frameworks/kirigami/commit/778e3be51bc4295c1a55f8c7a8c81498988c2a44