Bug 437796 - RFE: provide 24 hour option in system settings
Summary: RFE: provide 24 hour option in system settings
Status: RESOLVED DUPLICATE of bug 394698
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.21.90
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-28 18:26 UTC by rlk
Modified: 2021-06-09 00:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rlk 2021-05-28 18:26:02 UTC
Request that the system settings dialog provide an option for 24-hour clock.  Currently it is not possible to set a 24 hour clock, so times in e. g. Dolphin are always reported as AM/PM.  This is just my personal preference, but I don't believe I'm the only user with that preference.

There are other tickets open in this general area, e. g. 360163 and 308497, but the former appears to have a different focus and the latter appears to be against a specific tool.

The digital clock already offers this option.
Comment 1 Nate Graham 2021-06-08 21:08:18 UTC
You have to set a locale that uses 24-hour time in the "Time:" combobox. Unfortunately this means you're stuck with the other time-related settings for that locale. Hope you like them! :/

This is a limitation of Qt's QLocale component which unfortunately is rather dumb. We can at least make it easier to select specific formats visually rather than requiring that you be telepathic and know the settings for every locale already. For that, see Bug 394698. That's the only actionable thing here from the KDE side, so I'm marking the bug report as a duplicate of it.

*** This bug has been marked as a duplicate of bug 394698 ***
Comment 2 rlk 2021-06-09 00:32:40 UTC
...or, presumably, edit my current locale somehow.

This isn't the only completely braindead thing Qt has done with date/time; completely unrelated, comparing two QDateTimes is extremely slow because they don't want to add another 8 bytes to allow the time in milliseconds since the epoch to be cached, so every time I want to compare them, the date and time have to be converted into said milliseconds, involving locale lookups and timezone calculations.  I had fun fixing that in KPhotoAlbum.  Grr.