Bug 437390 - Password field loses focus after click on media controls
Summary: Password field loses focus after click on media controls
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Theme - Breeze (show other bugs)
Version: 5.21.5
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: visual-design
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-05-20 01:57 UTC by Patrick Silva
Modified: 2021-05-21 15:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-05-20 01:57:53 UTC
SUMMARY
Reproducible on both Arch Linux (Plasna 5.22 beta) and neon unstable.

STEPS TO REPRODUCE
1. play a media file with any player controlable by Media Player applet
2. lock your screen
3. pause playback using the media controls of the screen locker
4. try to unlock your screen

OBSERVED RESULT
screen can not be unlocked because the password field is not focused

EXPECTED RESULT
screen can be unlocked after click on media controls

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Graphics Platform: X11
Comment 1 Bug Janitor Service 2021-05-20 17:35:42 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/872
Comment 2 Bug Janitor Service 2021-05-20 22:10:52 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/873
Comment 3 Nate Graham 2021-05-21 15:03:53 UTC
Git commit 5c48f4a33527e3827ca0cd2d7c788119596ba8f3 by Nate Graham, on behalf of Jan Blackquill.
Committed on 21/05/2021 at 15:03.
Pushed by ngraham into branch 'master'.

lockscreen: make MediaControls tab-focus only

Users are unlikely to want focus diverted away from the
password field when interacting with the media controls;
setting the focus policy to TabFocus makes sure that
mouse usage doesn't divert focus while keeping keyboard
navigation intact.
FIXED-IN: 5.22

M  +3    -0    lookandfeel/contents/lockscreen/MediaControls.qml

https://invent.kde.org/plasma/plasma-workspace/commit/5c48f4a33527e3827ca0cd2d7c788119596ba8f3
Comment 4 Nate Graham 2021-05-21 15:04:24 UTC
Git commit bcc4ff7305dc0b5dc889391a871c66bfa22e7ee5 by Nate Graham, on behalf of Jan Blackquill.
Committed on 21/05/2021 at 15:04.
Pushed by ngraham into branch 'Plasma/5.22'.

lockscreen: make MediaControls tab-focus only

Users are unlikely to want focus diverted away from the
password field when interacting with the media controls;
setting the focus policy to TabFocus makes sure that
mouse usage doesn't divert focus while keeping keyboard
navigation intact.
FIXED-IN: 5.22


(cherry picked from commit 5c48f4a33527e3827ca0cd2d7c788119596ba8f3)

M  +3    -0    lookandfeel/contents/lockscreen/MediaControls.qml

https://invent.kde.org/plasma/plasma-workspace/commit/bcc4ff7305dc0b5dc889391a871c66bfa22e7ee5