Bug 437080 - The left pane changes its content before closing
Summary: The left pane changes its content before closing
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: split view (show other bugs)
Version: 21.04.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Felix Ernst
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-05-14 11:11 UTC by popov895
Modified: 2021-05-17 17:38 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.08


Attachments
Left pane closing (532.42 KB, video/mp4)
2021-05-14 11:11 UTC, popov895
Details

Note You need to log in before you can comment on or make changes to this bug.
Description popov895 2021-05-14 11:11:47 UTC
Created attachment 138412 [details]
Left pane closing

SUMMARY

As you can see on the attached video, when the left pane is closing, before the closing animation starts, its content are replaced with the content of the right pane. It looks weird. Can't we animate the closing of the left pane without changing its contents? With the right panel everything is fine in this regard.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: openSUSE Tumbleweed 20210511 / X11
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
KDE Gear: 21.04.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-05-14 15:15:28 UTC
Can confirm.
Comment 2 Bug Janitor Service 2021-05-17 13:20:08 UTC
A possibly relevant merge request was started @ https://invent.kde.org/system/dolphin/-/merge_requests/212
Comment 3 Felix Ernst 2021-05-17 16:49:47 UTC
Git commit 98e1fb66d054d188a7c07683e7e6768b84f63605 by Felix Ernst.
Committed on 17/05/2021 at 12:52.
Pushed by ngraham into branch 'master'.

Fix primary view changing folder for the closing animation

This commit fixes a bug which made it so an UrlNavigator that was
disconnected from a viewContainer would still indirectly control
the viewContainer because of a dubious connection created in
DolphinMainWindow.

Instead the internal UrlNavigator of the viewContainer is used
which is always connected to its own viewContainer.

This way the the supposedly disconnected primary UrlNavigator will
actually not affect the old disconnected viewContainer that is
currently being closed.
FIXED-IN: 21.08

M  +6    -7    src/dolphinmainwindow.cpp
M  +0    -3    src/dolphinmainwindow.h

https://invent.kde.org/system/dolphin/commit/98e1fb66d054d188a7c07683e7e6768b84f63605
Comment 4 Felix Ernst 2021-05-17 17:03:05 UTC
@popov895 Thanks for the bug report!
Comment 5 popov895 2021-05-17 17:38:16 UTC
Thanks for the fix!