Bug 437056 - Automatic spellcheck in `kate` does not persist
Summary: Automatic spellcheck in `kate` does not persist
Status: RESOLVED DUPLICATE of bug 436004
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 21.04.0
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-13 18:14 UTC by R (Chandra) Chandrasekhar
Modified: 2021-05-22 17:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R (Chandra) Chandrasekhar 2021-05-13 18:14:17 UTC
SUMMARY
Automatic spellcheck in kate is not persistent.

STEPS TO REPRODUCE
1. Automatic spell check enabled by default.
2. Type an erroneous word: it is highlighted.
3. Correct the error.
4. Type some more words with and without errors.
5. The erroneous words are not highlighted any more.
6. Toggle Ctrl-Shift-O and the errors show up again.

OBSERVED RESULT

Erroneous words added after a spellcheck correction are not highlighted.

EXPECTED RESULT

I would expect erroneous words to be highlighted regardless of previous errors being corrected. The Ctrl-Shift-O should not be necessary with automatic spellcheck on.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

Toggling Ctrl-Shift-O is a workaround but that makes a mockery of automatic spell checking.
Comment 1 Antonio Rojas 2021-05-22 17:17:48 UTC

*** This bug has been marked as a duplicate of bug 436004 ***