Bug 436999 - New calendar renders too many dots for months and years view
Summary: New calendar renders too many dots for months and years view
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.82.0
Platform: Neon Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: regression
: 438502 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-12 21:57 UTC by soee
Modified: 2021-07-24 10:12 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.83


Attachments
Buggy months view (97.68 KB, image/png)
2021-05-12 21:57 UTC, soee
Details
Multiple dots in the Calendar applet (54.87 KB, image/png)
2021-07-15 07:43 UTC, popov895
Details
Multiple dots in month view (32.62 KB, image/png)
2021-07-15 07:45 UTC, popov895
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soee 2021-05-12 21:57:40 UTC
Created attachment 138376 [details]
Buggy months view

With the new, redesigned calendar widget the dots were introduced to represents events for days. They work fine for days view but are rendered duplicated on whole width of the single month/year box on months and years view.


STEPS TO REPRODUCE
1. Click on the digital clock  widget
2. Switch calendar view to monts or years view

OBSERVED RESULT

The month/year box renders duplicated dots at the bottom.

EXPECTED RESULT

Probably month/year view should not render dots for events or show only one dot with number of events next to it instead of to many dots.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Neon 
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-05-12 22:00:53 UTC
Can confirm.
Comment 2 Carl Schwan 2021-05-13 15:30:10 UTC
Git commit 9a8613612f075f152d5306d1fe3226498217d34c by Carl Schwan.
Committed on 12/05/2021 at 22:30.
Pushed by ngraham into branch 'master'.

Fix events appearing in year or decade view

Bug is probably caused by using a DelegateModel on a simple ListModel.
Make sure we don't even try to load the event delegate when there is no
events or it's not a DayModel

M  +14   -11   src/declarativeimports/calendar/qml/DayDelegate.qml

https://invent.kde.org/frameworks/plasma-framework/commit/9a8613612f075f152d5306d1fe3226498217d34c
Comment 3 Patrick Silva 2021-06-12 13:19:58 UTC
*** Bug 438502 has been marked as a duplicate of this bug. ***
Comment 4 popov895 2021-07-15 07:43:55 UTC
Created attachment 140069 [details]
Multiple dots in the Calendar applet

I observe something like this, so I didn't file a new bug, but reopened this one.

STEPS TO REPRODUCE

1. Open Digital Clock applet
2. Check "Keep Open" button in the top right corner
3. Open Settings dialog (clicking "Configure Digital Clock..." button or menuitem with the same name in the context menu) and close it
4. Repeat step 3 several times

SOFTWARE/OS VERSIONS

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.3
Graphics Platform: X11
Comment 5 popov895 2021-07-15 07:45:29 UTC
Created attachment 140070 [details]
Multiple dots in month view

Same on month view, but not in years view.
Comment 6 Nate Graham 2021-07-23 13:45:30 UTC
That's odd--there are not supposed to be any dots at all in year view.

If you can reproduce the bug reliably, can you please file a new bug report for the issue and and add it to the "See also" field of this one? Thanks!
Comment 7 popov895 2021-07-24 10:12:55 UTC
Hmm, looks like it's just me.