Bug 436902 - Stutter on notification appearing/disappearing with Nvidia driver
Summary: Stutter on notification appearing/disappearing with Nvidia driver
Status: RESOLVED UPSTREAM
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: 5.21.4
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-11 00:02 UTC by Grzesiek11
Modified: 2021-05-11 18:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzesiek11 2021-05-11 00:02:37 UTC
SUMMARY
The entire desktop stutters when a notification appears (and when it disappears).

Video: https://youtu.be/V_DPYOPAvCE

Seems to only happen with the Nvidia driver.

STEPS TO REPRODUCE
1. Open glxgears or similar, it can help to use mangohud to make the stutter more visible (it shows a performance graph).
2. Open Konsole and run:

while true; do notify-send -t 2000 test; sleep 2; done

in the shell. This will spam some notifications for you.
3. Move some windows around

OBSERVED RESULT
glxgears stutters, and so does the entire desktop (moving windows).

EXPECTED RESULT
Nothing special happens, no stutter.

SOFTWARE/OS VERSIONS
Operating System: Debian GNU/Linux 11 (Sid)
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-19.1-liquorix-amd64
OS Type: 64-bit
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2400 CPU @ 3.10GHz
Memory: 7.7 GiB of RAM
Graphics Processor: GeForce GTX 660/PCIe/SSE2 (MSI GeForce GTX660 TWINFROZR III)
Nvidia Driver Version: 460.73.01

ADDITIONAL INFORMATION
I can't reproduce it on a Thinkpad x240 that has an Intel iGPU, but it is the case on my PC with Nvidia GTX 660.

It's irritating while playing games and noticeable while just using the desktop.

There also is some stutter when opening/closing windows, but I don't know if this is related, and it isn't that extreme.
Comment 1 Nate Graham 2021-05-11 18:28:43 UTC
Almost certainly an issue with the Nvidia driver itself. Please report this issue to the Nvidia folks, either by sending an email to linux-bugs@nvidia.com or making a post at https://forums.developer.nvidia.com/c/gpu-unix-graphics/linux/

It would be helpful to the Nvidia developers if you could run nvidia-bug-report.sh and attach the resulting file in your report. Thanks!