Bug 436608 - Persist annotation tool settings
Summary: Persist annotation tool settings
Status: RESOLVED FIXED
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 21.04.0
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
: 449071 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-05 03:12 UTC by King
Modified: 2022-01-24 12:25 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description King 2021-05-05 03:12:13 UTC
STEPS TO REPRODUCE
1. Open the annotation tool and change a few annotation tool settings from their defaults. For example, I often use the Rectangle tool, change the color to red (default is gray), and switch to "Border and No Fill" (default is filled).
2. Annotate the image, hit Annotation done, and close Spectacle.
3. Re-open Spectacle, take another screenshot and re-open the annotation tool.

OBSERVED RESULT
Annotation tool settings revert to their defaults.

EXPECTED RESULT
Previously selected tool settings are restored.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE neon 5.21
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Comment 1 Patrick Silva 2021-05-23 14:12:47 UTC
This is my wish too. It's annoying to set my preferred settings for Text tool again every time I want to use it because they were not remembered when closing Spectacle last time I used said tool.
Comment 2 Bug Janitor Service 2021-12-05 18:36:26 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/105
Comment 3 Antonio Prcela 2021-12-06 17:47:58 UTC
Git commit 473d554a1d085d40d7d07dfccc9991f65f96e979 by Antonio Prcela.
Committed on 05/12/2021 at 18:34.
Pushed by ngraham into branch 'master'.

Save Annotation tool settings across launches

Save Annotation tool settings across launches, so the user always has, for example,
the same font settings in the annotator.

M  +1    -0    src/Gui/KSWidget.cpp

https://invent.kde.org/graphics/spectacle/commit/473d554a1d085d40d7d07dfccc9991f65f96e979
Comment 4 Patrick Silva 2022-01-24 12:25:30 UTC
*** Bug 449071 has been marked as a duplicate of this bug. ***