Bug 436129 - Activity Panel Crash
Summary: Activity Panel Crash
Status: RESOLVED WORKSFORME
Alias: None
Product: lattedock
Classification: Plasma
Component: application (show other bugs)
Version: 0.9.11
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michail Vourlakos
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-04-24 16:23 UTC by mrbscottc
Modified: 2021-06-01 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrbscottc 2021-04-24 16:23:47 UTC
Application: latte-dock (0.9.11)
 (Compiled from sources)
Qt Version: 5.15.2
Frameworks Version: 5.81.0
Operating System: Linux 5.4.0-72-generic x86_64
Windowing System: Wayland
Drkonqi Version: 5.21.4
Distribution: KDE neon User Edition 5.21

-- Information about the crash:
- What I was doing when the application crashed:  I was trying to resize and make adjustments to the activity panel at the top of my screen. This was because it automatically resized after logging in under Wayland for the first time. The only thing I did just after login was to change the wallpaper. I tried to lengthen and then maximise the panel for full screen width.  I added a spacer and then moved the spacer and that's when the crash occurred.

- Custom settings of the application:

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Latte Dock (latte-dock), signal: Aborted

[New LWP 1426]
[New LWP 1428]
[New LWP 1429]
[New LWP 1430]
[New LWP 1431]
[New LWP 1555]
[New LWP 1657]
[New LWP 1658]
[New LWP 1660]
[New LWP 1663]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f30730caaff in __GI___poll (fds=0x7fffe6b43ee8, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
[Current thread is 1 (Thread 0x7f306f4808c0 (LWP 1361))]

Thread 11 (Thread 0x7f302ef7e700 (LWP 1663)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x7f306801a7a0) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f306801a750, cond=0x7f306801a778) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f306801a778, mutex=0x7f306801a750) at pthread_cond_wait.c:638
#3  0x00007f30735aad5b in QWaitConditionPrivate::wait (deadline=..., this=0x7f306801a750) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=<optimized out>, mutex=0x55e170804c90, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007f307540d814 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f307540dc89 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f30735a4bec in QThreadPrivate::start (arg=0x55e170804bf0) at thread/qthread_unix.cpp:329
#8  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 10 (Thread 0x7f302ffff700 (LWP 1660)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55e1707d5e24) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55e1707d5dd0, cond=0x55e1707d5df8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55e1707d5df8, mutex=0x55e1707d5dd0) at pthread_cond_wait.c:638
#3  0x00007f30735aad5b in QWaitConditionPrivate::wait (deadline=..., this=0x55e1707d5dd0) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=<optimized out>, mutex=0x55e1708b4bc0, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007f307540d814 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f307540dc89 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f30735a4bec in QThreadPrivate::start (arg=0x55e1708b4b20) at thread/qthread_unix.cpp:329
#8  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 9 (Thread 0x7f3045488700 (LWP 1658)):
#0  0x00007f307176b8f5 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f307176d345 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f307176e82b in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f307176f29b in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f307176f4a3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f30737e4ffb in QEventDispatcherGlib::processEvents (this=0x7f3028000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f30737891eb in QEventLoop::exec (this=this@entry=0x7f3045487cc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007f30735a3a52 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007f3075090fa9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f30735a4bec in QThreadPrivate::start (arg=0x55e1705c1260) at thread/qthread_unix.cpp:329
#10 0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#11 0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7f3045c8a700 (LWP 1657)):
#0  0x00007f3071799049 in g_thread_self () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f307176f493 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f30737e4ffb in QEventDispatcherGlib::processEvents (this=0x7f3034000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#3  0x00007f30737891eb in QEventLoop::exec (this=this@entry=0x7f3045c89ce0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#4  0x00007f30735a3a52 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#5  0x00007f30735a4bec in QThreadPrivate::start (arg=0x55e16f9e23e0) at thread/qthread_unix.cpp:329
#6  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f3052de1700 (LWP 1555)):
#0  0x00007f30730caaff in __GI___poll (fds=0x7f304c004e60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f307176f36e in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f307176f4a3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f30737e4ffb in QEventDispatcherGlib::processEvents (this=0x7f304c000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f30737891eb in QEventLoop::exec (this=this@entry=0x7f3052de0cc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f30735a3a52 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f3075090fa9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f30735a4bec in QThreadPrivate::start (arg=0x55e16fa32a60) at thread/qthread_unix.cpp:329
#8  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f3066ffd700 (LWP 1431)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55e16f9079f8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55e16f9079a8, cond=0x55e16f9079d0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55e16f9079d0, mutex=0x55e16f9079a8) at pthread_cond_wait.c:638
#3  0x00007f306d38be6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f306d38ba6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f30677fe700 (LWP 1430)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55e16f9079f8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55e16f9079a8, cond=0x55e16f9079d0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55e16f9079d0, mutex=0x55e16f9079a8) at pthread_cond_wait.c:638
#3  0x00007f306d38be6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f306d38ba6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f3067fff700 (LWP 1429)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55e16f9079f8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55e16f9079a8, cond=0x55e16f9079d0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55e16f9079d0, mutex=0x55e16f9079a8) at pthread_cond_wait.c:638
#3  0x00007f306d38be6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f306d38ba6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f306cc59700 (LWP 1428)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55e16f9079f8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55e16f9079a8, cond=0x55e16f9079d0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55e16f9079d0, mutex=0x55e16f9079a8) at pthread_cond_wait.c:638
#3  0x00007f306d38be6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f306d38ba6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f306e7a6700 (LWP 1426)):
#0  __GI___libc_read (nbytes=16, buf=0x7f306e7a5aa0, fd=7) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=7, buf=0x7f306e7a5aa0, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f30717b7b2f in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f307176eebe in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f307176f312 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f307176f4a3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f30737e4ffb in QEventDispatcherGlib::processEvents (this=0x7f3068000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#7  0x00007f30737891eb in QEventLoop::exec (this=this@entry=0x7f306e7a5cb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#8  0x00007f30735a3a52 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#9  0x00007f3073a46f4b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#10 0x00007f30735a4bec in QThreadPrivate::start (arg=0x7f3073acad80) at thread/qthread_unix.cpp:329
#11 0x00007f3072470609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#12 0x00007f30730d7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f306f4808c0 (LWP 1361)):
[KCrash Handler]
#4  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#5  0x00007f3072fda859 in __GI_abort () at abort.c:79
#6  0x00007f3073569bf7 in qt_message_fatal (context=..., message=<synthetic pointer>...) at global/qlogging.cpp:1914
#7  QMessageLogger::fatal (this=this@entry=0x7fffe6b44a40, msg=msg@entry=0x7f30722820f8 "The Wayland connection experienced a fatal error: %s") at global/qlogging.cpp:893
#8  0x00007f30721d6484 in QtWaylandClient::QWaylandDisplay::checkError (this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlogging.h:90
#9  0x00007f30721d716c in QtWaylandClient::QWaylandDisplay::flushRequests (this=0x55e16f5ffba0) at qwaylanddisplay.cpp:222
#10 0x00007f30737c1730 in doActivate<false> (sender=0x55e16f635720, signal_index=4, argv=0x7fffe6b44b50) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:395
#11 0x00007f30737baac7 in QMetaObject::activate (sender=sender@entry=0x55e16f635720, m=m@entry=0x7f3073a241c0 <QAbstractEventDispatcher::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3946
#12 0x00007f3073787287 in QAbstractEventDispatcher::awake (this=this@entry=0x55e16f635720) at .moc/moc_qabstracteventdispatcher.cpp:149
#13 0x00007f30737e501c in QEventDispatcherGlib::processEvents (this=0x55e16f635720, flags=...) at kernel/qeventdispatcher_glib.cpp:430
#14 0x00007f30737891eb in QEventLoop::exec (this=this@entry=0x7fffe6b44c70, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#15 0x00007f3073791394 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#16 0x000055e16ebb641b in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:285
[Inferior 1 (process 1361) detached]

Possible duplicates by query: bug 429344, bug 427384, bug 424911, bug 423951, bug 423222.

Reported using DrKonqi
This report was filed against 'kde' because the product 'latte-dock' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Michail Vourlakos 2021-04-27 18:13:40 UTC
0.9.11 is not maintained any more.

In any case this is an Activity Pager crash under wayland. It will be fixed upstream.
Comment 2 Michail Vourlakos 2021-05-02 06:52:59 UTC
feedback
Comment 3 Bug Janitor Service 2021-05-17 04:33:35 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2021-06-01 04:33:39 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!