Bug 436089 - Allow deletion of attachments and other message parts from message structure view
Summary: Allow deletion of attachments and other message parts from message structure ...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: commands and actions (show other bugs)
Version: Git (master)
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Ingo Klöcker
URL:
Keywords:
: 361368 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-04-23 10:02 UTC by Ingo Klöcker
Modified: 2021-05-10 16:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.18.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Klöcker 2021-04-23 10:02:21 UTC
It should be possible to delete attachments and other message parts via the context menu of the message structure view.
Comment 1 Ingo Klöcker 2021-04-23 10:02:46 UTC
taking
Comment 2 Ingo Klöcker 2021-04-23 10:16:43 UTC
Git commit 0b53b36701f4fe44dfa46af120bc0c71d327040c by Ingo Klöcker.
Committed on 23/04/2021 at 10:15.
Pushed by kloecker into branch 'master'.

Allow deletion of attachments from message structure view

Deletion of attachments (and other message parts) is only allowed
one at a time. Message parts inside encrypted message parts cannot
be deleted.

This (re-)adds the "Delete Attachment" action to the context menu
of the message structure view. It was removed 3 years ago because
it always crashed (because it tried to work with a copy of the node
tree of the original message).

Sponsored by: Intevation GmbH
Related: bug 287177
FIXED-IN: 5.18.0

M  +22   -1    messageviewer/src/viewer/viewer_p.cpp
M  +1    -0    messageviewer/src/viewer/viewer_p.h

https://invent.kde.org/pim/messagelib/commit/0b53b36701f4fe44dfa46af120bc0c71d327040c
Comment 3 Ingo Klöcker 2021-05-10 16:04:17 UTC
*** Bug 361368 has been marked as a duplicate of this bug. ***