Bug 435866 - No ledger icon in the pane of the left side
Summary: No ledger icon in the pane of the left side
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Applications
Component: packaging (show other bugs)
Version: 5.1.1
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks: 435581
  Show dependency treegraph
 
Reported: 2021-04-18 07:19 UTC by Ralf Habacker
Modified: 2021-06-30 06:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.3


Attachments
screenshot showing colored icons build from master branch (30.17 KB, image/png)
2021-04-24 12:38 UTC, Ralf Habacker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Habacker 2021-04-18 07:19:13 UTC
SUMMARY

kmymoney has 20 png icons of its own under /share/kmymoney/icons, e.g. the ledger icon. Those were present in the latest stable windows build 5.06 and unstable 5.07. In 5.1.1 there is just no icon now.

STEPS TO REPRODUCE
1. Download portable package for kmymoney from https://kmymoney.org/snapshots.php
2. unpack 7z file
3. start kmymoney
4. inspect the icon pane of the left side

OBSERVED RESULT
ledger icon is not shown

EXPECTED RESULT
ledger icon should be displayed

SOFTWARE/OS VERSIONS
Windows: 10
KDE Frameworks Version: 5.65.0
Qt Version: 5.9
Comment 1 AndreJ 2021-04-18 11:00:53 UTC
In Version 5.07, the icon was taken from
C:\Program Files\kmymoney5\share\kmymoney\icons\hicolor
while the rest of the icons was taken from the icontheme.rcc file which was build from the breeze iconset. I guess the ledger icon (and about 20 others from the same hicolor folder) have to be taken into the icontheme.rcc file.
Comment 2 Ralf Habacker 2021-04-24 12:38:23 UTC
Created attachment 137866 [details]
screenshot showing colored icons build from master branch

The issue seems to be related to the 5.1 branch only, because it has been fixed in the master branch.
Comment 3 Dawid Wróbel 2021-06-30 06:08:50 UTC
Git commit f700cfb15809ec7b5e182d9e3947a5c3250ac029 by Dawid Wróbel.
Committed on 30/06/2021 at 06:08.
Pushed by wrobelda into branch '5.1'.

Also fix bank/institution, account icons

M  +3    -2    kmymoney/icons/icons.cpp

https://invent.kde.org/office/kmymoney/commit/f700cfb15809ec7b5e182d9e3947a5c3250ac029
Comment 4 Dawid Wróbel 2021-06-30 06:31:48 UTC
Git commit 483b954791ccf4d7cfdcd2da659918dc0f1059a0 by Dawid Wróbel.
Committed on 30/06/2021 at 06:31.
Pushed by wrobelda into branch '5.1'.

Also fix transaction icon

M  +4    -1    kmymoney/icons/icons.cpp

https://invent.kde.org/office/kmymoney/commit/483b954791ccf4d7cfdcd2da659918dc0f1059a0