Bug 435776 - Some images in HTML display are washed out
Summary: Some images in HTML display are washed out
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: 5.16.3
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-15 15:10 UTC by David C. Bryant
Modified: 2021-05-04 16:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of a washed-out image (91.12 KB, image/png)
2021-04-15 15:17 UTC, David C. Bryant
Details
Screenshot of the same image when displayed as an attachment not embedded in an email message. (105.58 KB, image/png)
2021-04-15 15:22 UTC, David C. Bryant
Details
The raw email message (.mbox format, but called .txt). (82.40 KB, text/plain)
2021-04-15 15:30 UTC, David C. Bryant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David C. Bryant 2021-04-15 15:10:31 UTC
SUMMARY
Most images embedded in HTML messages appear just fine. But occasionally a screenshot appears to be totally overexposed / washed out when the underlying image file looks perfectly fine.

STEPS TO REPRODUCE
1. Take a screenshot of something in your browser (I used Flameshot).
2. Embed the picture in an email message.
3. Send it to yourself, then look at it.

OBSERVED RESULT
Sometimes the image looks all washed out, even when the original image looks good.


EXPECTED RESULT
I expect all the embedded images in an HTML-encoded message to be displayed sharply and clearly.


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: *
(available in About System)
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
See attached screenshots, which I'll upload in a minute or two. I'll also upload the raw email message file.
Comment 1 David C. Bryant 2021-04-15 15:17:50 UTC
Created attachment 137634 [details]
Screenshot of a washed-out image

This is a screenshot of an image as it appears in the normal HTML display.
Comment 2 David C. Bryant 2021-04-15 15:22:28 UTC
Created attachment 137635 [details]
Screenshot of the same image when displayed as an attachment not embedded in an email message.

This is what the image looks like when I view the attachment in the KMail preview pane as a separate item, and not as part of a message.
Comment 3 David C. Bryant 2021-04-15 15:30:18 UTC
Created attachment 137636 [details]
The raw email message (.mbox format, but called .txt).

This is the raw email message I used to make the two preceding screenshots.
Comment 4 David C. Bryant 2021-04-15 15:37:49 UTC
Let me know if you want more examples. I'll do some goofing around with other image creation programs (Spectacle, Firefox "screenshot" tool, etc.) if you think that might be helpful. This doesn't happen very often, and only seems to occur when I create a screenshot myself. (In this instance, I uploaded an image to the groups.io web site, and sent the email message from the web site.) Thanks!
Comment 5 David C. Bryant 2021-05-04 16:31:54 UTC
More information. This *only* happens with one sender. In most of the messages that I receive the images are fine. But if the message originates from http://groups.io, this error pops up. I'll ask about it at the groups.io web site.