Bug 435722 - Clear History button remembers "No" choice
Summary: Clear History button remembers "No" choice
Status: RESOLVED DUPLICATE of bug 336053
Alias: None
Product: klipper
Classification: Applications
Component: plasma-widget (show other bugs)
Version: unspecified
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-14 12:32 UTC by Thoben Bauer
Modified: 2021-04-14 13:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thoben Bauer 2021-04-14 12:32:32 UTC
SUMMARY
On a fresh install of KDE Plasma, the "Clear History" button of the clipboard widget becomes permanently nonfunctional if one selects "No" and "Do not ask again" in the following confirmation dialog.

STEPS TO REPRODUCE
1. Copy something to clipboard
2. Open the Clipboard widget, Click the "Clear History" button
3. In the confirmation dialog, check "Do not ask again" and click "No"

OBSERVED RESULT
"Clear History" button becomes nonfunctional. History cannot be cleared anymore.
Functionality can be restored by manually editing ~/.config/plasmashellrc and removing the line "really_clear_histoy=false"

EXPECTED RESULT
When clicking "Clear History", the confirmation dialog appears again.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 5.11
(available in About System)
KDE Plasma Version: 5.21.3 
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-04-14 13:46:24 UTC

*** This bug has been marked as a duplicate of bug 336053 ***