Bug 435504 - Preview panel shows misleading message
Summary: Preview panel shows misleading message
Status: RESOLVED DUPLICATE of bug 390002
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.16.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-08 12:46 UTC by Freek de Kruijf
Modified: 2022-02-22 20:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (11.84 KB, image/png)
2021-04-08 12:50 UTC, Freek de Kruijf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2021-04-08 12:46:51 UTC
SUMMARY
Preview panel shows misleading message about LibreOffice odt file

STEPS TO REPRODUCE
1. Open a message with a LibreOffice odt file attached in de preview panel
2. Part of the panel shows the attached picture
3. The message tells the file is encrypted (Dutch versleuteld), which it is not. The format of an odt file is compressed, but this is the standard.

OBSERVED RESULT


EXPECTED RESULT
There should not be a message at all; normal file format.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 20.12.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Freek de Kruijf 2021-04-08 12:50:47 UTC
Created attachment 137431 [details]
screenshot

Screenshot of misleading message. .odt file is not encrypted (versleuteld)
Comment 2 Freek de Kruijf 2021-04-08 12:53:08 UTC
Apparently not all .odt files are recognized as encrypted. Some are considered normal files.
Comment 3 Jonathan Marten 2021-04-08 16:48:13 UTC
Also seen with MS Word (.doc) files, see bug 390002.

Suspect that GpgME's detection of encrypted parts is too sensitive, suggested fix is there.
Comment 4 Jonathan Marten 2022-02-22 20:32:10 UTC
Assumed fixed along with bug 390002.  Please reopen if still seen with .odt files.

*** This bug has been marked as a duplicate of bug 390002 ***