Bug 435279 - When the user starts typing with the Plasma Monitor open, the Search Box should become immediately focused regardless of which page is currently being shown.
Summary: When the user starts typing with the Plasma Monitor open, the Search Box shou...
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.21.3
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-04-02 19:50 UTC by Alexander M.
Modified: 2021-04-29 11:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander M. 2021-04-02 19:50:44 UTC
SUMMARY

In the previous incarnation of System Monitor, a user could easily and quickly search for a specific process by opening the System Monitor with its shortcut and then just typing the process's name.

In this new version, a user must open the System Monitor, manually switch to the "Processes" page or the "Applications" page, *manually* focus the Search Box, and only then are they able to start typing the process's name.


STEPS TO REPRODUCE

1. Open the new Plasma System Monitor.
2. Start typing.
3. Sigh and manually click the "Processes"/"Applications" page
4. Start typing.
5. Sigh and manually click inside the Search Box to focus it.
6. Start typing.

OBSERVED RESULT

The Search Box is never focused unless the user manually clicks on it.


EXPECTED RESULT

Not only should the Search Box become focused by default when the user starts typing, but preferably it should become focused when the user starts typing *regardless* if a Search Box-less page like "Overview" is currently being shown.

Ideally it should be user-configurable which Search Box will be focused by default (the one in the "Processes" page, the one in the "Applications" page, or one in a custom page created by the user, since the application already provides that functionality).


SOFTWARE/OS VERSIONS

OS: Arch Linux 
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-04-06 03:38:38 UTC
Yeah some kind of quick search on the overview page's toolbar might be nice to support this legitimate use case.
Comment 2 Bug Janitor Service 2021-04-16 10:33:28 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-systemmonitor/-/merge_requests/116
Comment 3 David Redondo 2021-04-16 12:44:38 UTC
Git commit 41d94c4629fff96d202e31dfa7eede1fb93818f8 by David Redondo.
Committed on 16/04/2021 at 10:23.
Pushed by davidre into branch 'master'.

Focus search field by default in Application/ProcessView

M  +1    -0    src/faces/applicationstable/contents/ui/FullRepresentation.qml
M  +1    -0    src/faces/processtable/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-systemmonitor/commit/41d94c4629fff96d202e31dfa7eede1fb93818f8
Comment 4 David Redondo 2021-04-29 11:42:24 UTC
Git commit 9c2d8b7676ec68b60a6f8e991d61c12b6575ad17 by David Redondo.
Committed on 29/04/2021 at 11:39.
Pushed by davidre into branch 'master'.

Allow specifying which page to open on start

Adds a combobox to the page edit dialog where one can choose with which
page to start or always open the last opened page.
Related: bug 429417
FIXED-IN:5.22

M  +0    -4    src/main.cpp
M  +13   -0    src/main.qml
M  +65   -0    src/page/PageSortDialog.qml
M  +4    -0    src/systemmonitor.kcfg

https://invent.kde.org/plasma/plasma-systemmonitor/commit/9c2d8b7676ec68b60a6f8e991d61c12b6575ad17