Bug 435082 - Spectacle fails to include mouse pointer using shortcut
Summary: Spectacle fails to include mouse pointer using shortcut
Status: RESOLVED DUPLICATE of bug 392057
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 20.12.3
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-28 20:21 UTC by medin
Modified: 2021-03-31 19:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description medin 2021-03-28 20:21:13 UTC
When a screenshot is captured using shortcut without launching Spectacle if fails to include mouse pointer even if the option is previously selected in Spectacle interface (I don't know if that option is global that also applies to shortcut mode or only usable when Spectacle is shown and user clicks on "Take a New Screenshot" button). Using shortcuts, both Full Screen and Active Window capture modes fail to include mouse pointer, but Rectangular region succeed to include it.
Comment 1 Nate Graham 2021-03-31 17:15:44 UTC

*** This bug has been marked as a duplicate of bug 392057 ***
Comment 2 medin 2021-03-31 18:33:28 UTC
The goal of bug 392057 is the opposite of this bug.
Comment 3 Nate Graham 2021-03-31 19:14:53 UTC
It's the same. That bug report proposes making it read spectacle's config file to respect your preference. Right now whether to include the pointer or not is a random hardcoded thing.
Comment 4 medin 2021-03-31 19:24:50 UTC
(In reply to Nate Graham from comment #3)
> It's the same. That bug report proposes making it read spectacle's config
> file to respect your preference. Right now whether to include the pointer or
> not is a random hardcoded thing.

All screenshots modes that are captured using shortcuts should follow pointer settings that appears in main Spectacle, and from what I see that pointer option is also global for all non shortcut capture modes.
Comment 5 Nate Graham 2021-03-31 19:27:15 UTC
(In reply to medin from comment #4)
> All screenshots modes that are captured using shortcuts should follow
> pointer settings that appears in main Spectacle
Yes, it should. And that's what Bug 392057 is all about.