Bug 435018 - Plasmoid config sidebar no longer highlights Wallpaper page
Summary: Plasmoid config sidebar no longer highlights Wallpaper page
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Desktop Containment (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Carl Schwan
URL:
Keywords:
: 436160 446611 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-27 14:06 UTC by Kai Uwe Broulik
Modified: 2022-05-17 17:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
Dialog without highlight (177.58 KB, image/png)
2021-03-27 14:06 UTC, Kai Uwe Broulik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2021-03-27 14:06:46 UTC
Created attachment 137104 [details]
Dialog without highlight

SUMMARY
Since the switch to column view, the currently viewed page in applet config dialog is no longer continuously highlighted.

STEPS TO REPRODUCE
1. Right click desktop
2. "Configure wallpaper"

OBSERVED RESULT
"Wallpaper" item in sidebar is not highlighted

EXPECTED RESULT
"Wallpaper" item is always highlighted while on that page

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Git master as of 24 March

ADDITIONAL INFORMATION
The dialog also takes quite long to load..
Comment 1 Nate Graham 2021-03-27 14:08:22 UTC
Looks like it only affects that page for me. All the other pages in that window, and in other windows for other apples, highlight fine for me.

Carl, could you take a look? Thanks!
Comment 2 Patrick Silva 2021-06-01 15:30:33 UTC
*** Bug 436160 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2021-12-07 21:12:28 UTC
*** Bug 446611 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-05-17 17:57:11 UTC
Fixed by Fushan Wen with https://invent.kde.org/plasma/plasma-desktop/-/commit/5b362f137bcd5de5daa9d8f3ae4953b0da493c13 in Plasma 5.25!