Bug 434972 - RTL widget resizing problem in edit mode
Summary: RTL widget resizing problem in edit mode
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Desktop Containment (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: ratijas
URL:
Keywords: rtl
: 453116 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-26 14:01 UTC by Omeritzics
Modified: 2022-06-04 15:45 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
A video showing the problem (3.16 MB, video/webm)
2021-03-29 12:56 UTC, Omeritzics
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Omeritzics 2021-03-26 14:01:16 UTC
SUMMARY
Problems with widgets resizing in edit mode using RTL languages.

STEPS TO REPRODUCE
1. Use an RTL language (Hebrew, Arabic, Persian, etc.)
2. Add a widget to the desktop.
3. Try to resize it (horizontally) to experience the problem.

OBSERVED RESULT
RTL problems with resizing the widgets in edit mode.

EXPECTED RESULT
Resize the widgets in edit mode easily.
Comment 1 Omeritzics 2021-03-29 12:56:45 UTC
Created attachment 137154 [details]
A video showing the problem
Comment 2 Nate Graham 2021-03-31 16:59:53 UTC
can confirm.
Comment 3 ratijas 2022-06-01 18:09:05 UTC
The funniest part is not even this. Try resizing from corners to really feel the power of LayoutMirroring!
Comment 4 Bug Janitor Service 2022-06-01 18:39:07 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1795
Comment 5 Nate Graham 2022-06-02 18:51:13 UTC
Git commit e2244b63bf3c5282d985dbee5696bf32b38dcd28 by Nate Graham, on behalf of ivan tkachenko.
Committed on 02/06/2022 at 18:43.
Pushed by ngraham into branch 'master'.

[containment] Fix applet resizing in Edit Mode with RTL layout direction

M  +3    -0    components/containmentlayoutmanager/qml/ConfigOverlayWithHandles.qml

https://invent.kde.org/plasma/plasma-workspace/commit/e2244b63bf3c5282d985dbee5696bf32b38dcd28
Comment 6 Nate Graham 2022-06-02 19:22:09 UTC
Git commit 18c98349835ff508abda0000381d63e30f064315 by Nate Graham, on behalf of ivan tkachenko.
Committed on 02/06/2022 at 19:22.
Pushed by ngraham into branch 'Plasma/5.25'.

[containment] Fix applet resizing in Edit Mode with RTL layout direction


(cherry picked from commit e2244b63bf3c5282d985dbee5696bf32b38dcd28)

M  +3    -0    components/containmentlayoutmanager/qml/ConfigOverlayWithHandles.qml

https://invent.kde.org/plasma/plasma-workspace/commit/18c98349835ff508abda0000381d63e30f064315
Comment 7 Zayed Al-Saidi 2022-06-04 15:45:52 UTC
*** Bug 453116 has been marked as a duplicate of this bug. ***