Bug 434665 - Add action to navigate to sibling directory
Summary: Add action to navigate to sibling directory
Status: RESOLVED DUPLICATE of bug 387455
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: URL navigator (show other bugs)
Version: 5.80.0
Platform: Archlinux Linux
: NOR wishlist
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-20 13:32 UTC by Frank Steinmetzger
Modified: 2021-03-20 23:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2021-03-20 13:32:16 UTC
SUMMARY
In programs like Dolphin and Gwenview there is always the possibility to go to a sibling directory by using the scroll wheel on the last part of the address in a breadcrumbs address bar. I would like to propose a new action that does exactly this, so it can be assigned to a keyboard shortcut. The default could be <Alt+PgUp> for previous and <Alt+PgDn> for next directory. This would make keyboard-only use of Dolphin much more viable. Iā€™m not quite sure how to handle the first and last directory. Either just stop or maybe go to the next sibling of its parent?


RATIONALE
In Dolphin, it is possible to navigate throughout the directory tree with <Enter>, <Backspace>, <Alt+Up>, cursor keys and so on. I often peruse through many directories in one session, such as music albums or photo directories. While this already is possible with the keyboard, it is rather elaborate:

1) In detailed (tree) view: expand the tree with <Right>, look into it, collapse it with <Left> and go to the next with <Down> or <Up>. Problems arise if the content of the expanded directory is larger than the window can show because scrolling becomes necessary, which is always a hassle with the keyboard and in this case moves the current selection away from the directory.

2) In all views: press <Enter> to go into the directory, browse around, press backspace and then a cursor key to go to the next sibling. This is actually more efficient than 1) because scrolling has no effect on directory selection. But both methods require lots of key presses.


As a reference, the column-oriented console file manager Ranger has such a function which is triggered by default with the [ and ] keys.

Thanks for your consideration.
Comment 1 Nate Graham 2021-03-20 23:56:16 UTC
I agree with you and I have the same annoyance when I need to perform these kinds or navigation workflows. I think the best way to do this is to just add column-based navigation, like Dolphin used to have, and like it could perhaps have again.

*** This bug has been marked as a duplicate of bug 387455 ***